I have created a group policy to set up Folder Redirection. The client computers are all Windows 10 Enterprise. I followed these instructions.


Additionally, I gave the "Domain Computers" and "Authenticated Users" groups read permissions on the GPO.

For the purpose of testing, my regular and elevated domain accounts are the only ones in the group. Also for testing, I'm only redirection "Desktop" and "Documents". When I logged into a Windows 10 computer, the redirection did not happen at all. GPResult shows that the GPO applied successfully, the settings just are not implemented. Eventually, I also created WMI filter for Windows 10. This by itself did not fix my issue. GPResult showed WMI filter as true, but still didn't apply the settings. Through more testing, I found that a newly imaged Windows 10 computer would redirect my folders properly. I decided to remove my profile from a computer that I had already logged onto and folder redirection was not working. After removing the profile and logging back in, the folder redirection works.

But I cannot do this manually for all the users and computers in our organization. I need to find the reason this is not working when a user has already established a profile.

A duplicate GPO with no WMI Filter is used for logging onto servers (all servers are Server 2012 R2). Redirection works as intended on Server 2012 R2. No need to remove existing profiles.

I followed troubleshooting steps from this site and found nothing helpful. Even the trace file showed no failures.


Any assistance on what else I could do to troubleshoot this would be greatly appreciated.


What options do you have on the Settings tab for Move the contents of Documents to the new location? It sounds like that was not enabled, and it should be. Probably also a good idea to enable the Redirect back to local option if the policy is ever removed. gpoSettings

| improve this answer | |
  • "Grant the user exclusive rights", "Move the contents of df Desktop to the new location" and "Redirect the folder back to the local userprofile location when policy is removed" has been set since the beginning of my testing. I did try unchecking the "Grant the user exclusive rights" setting, but that didn't help. I have not tried the one that applies to XP and earlier since we're all Windows 10. – user3271408 Jun 21 '18 at 11:24

important things to consider for redirected folders:

  • Users need full access on the Share and on the BaseFolder for the redirection target
  • Users have to have respective ownership of their individual redirected target folders. Simplest way to achieve this is by deleting folder on the share and relogging.
  • if there's still no user folder on the share you might need to reset offline folders on the specific client computer:

    1. reg add HKLM\SYSTEM\CurrentControlSet\services\CSC\Parameters /v FormatDatabase /t REG_DWORD /d 1 (Option 3 in http://www.networknet.nl/apps/wp/archives/1093)

    2. Restart

| improve this answer | |
  • Thank you for the response. It is not a permission issue because the same user gets redirected properly when a user profile does not exist on a computer prior to the policy taking affect. Even if that fixes the problem for one computer, I don't want to need to go to each computer for this. – user3271408 Jun 26 '18 at 13:53

The problem ended up being a group policy loopback setting that was configured by someone else.

| improve this answer | |
  • Any chance you could make this answer more specific and detailed? – 3D1T0R Dec 26 '18 at 20:51
  • Here is a link about the setting: blogs.technet.microsoft.com/askds/2013/05/21/… When I would change a setting that should effect the user account that I was testing with, the group policy would process it but this loopback setting kept over writing my user account setting with the computer account setting. – user3271408 Dec 27 '18 at 21:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.