0

I have setup Linodes longview (which is used to view your servers information from the linode dashboard). All is working apart from the Apache tab, which gives the following error:

Unable to access local server status for Apache at
http://127.0.0.1/server-status?auto: 500 Can't connect to 
127.0.0.1:443 (hostname verification failed)

I know that the above is caused by a 301 redirect to "https://127.0.0.1/server-status"

What I can't figure out is how I will get around this. As far as I see it I have three options:

1) Get rid of the redirect
2) Create a self signed SSL certificate for 127.0.0.1
3) Set the target to "https://127.0.0.1:443/server-status?auto" and somehow get the server to ignore the fact there is no certificate

Option 1 is preferable, but I cannot for the life of me figure out where the redirect is coming from. I have SSL setup for all my domains in the /etc/apache2/sites-available/ folder, but I can't see how this would relate to localhost (127.0.0.1).

Option 2 I think is most likely to work but is also the biggest pain.

Option 3 is likely not possible, but you can achieve this with:

 curl -k -L 127.0.0.1/server-status

from the command line in ubuntu (-k ignores lack of certificate -L follows redirects). I should also point out that the above command returns the data that is meant to go to longview, so I also know the rest of the setup is OK.

Any advice is welcome...

Just for info I'm running Ubuntu Server 18.04 LTS with apache2.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.