My current configuration is a Dell PowerEdge SC440 server with 2 SATA 160 GB drives in RAID 1 configuration. I bought two 1 TB drives and I want to replace the 160 GB with these 1 TB drives. There is only 1 partition on the virtual drive.

The first thing I tried was to remove 1 160 GB drive and replace it with a 1 TB drive. The 1 TB synched correctly, so I replaced the other 1 TB drive and that synched successfully. I was hoping I could extend the partition or at least create a new partition with the unused space. Unfortunately the Disk Management snapin only sees the virtual drive as 160 GB. I tried use Gparted, but it only recognized the virtual drive as 160 GB.

My question is what is the recommended way to acquire the extra space in the 1 TB? Can I take one of the 160 GB drives out, stick it in another computer and clone that drive, stick that back in the server, stick the other 160 GB drive in and sync that with the newly cloned driver? Or is there another easier way to do what I need to do?

I would prefer to solve this problem with freely available software.


4 Answers 4


Does this server have a PERC or other RAID controller?

Check the RAID controller configuration to see if you can grow the hardware RAID volume.

Then use gparted to grow the NTFS into the new space.

  • The SC440 came with a SAS 5i/R RAID controller card, and as far as I can tell there's no option to grow the volume. Dec 7, 2009 at 18:24

The safest and easiest way to do do this would be to:

  2. Pull both 160GB drives out (now you have 3 backups for all intents and purposes)
  3. Put the 1TB drives in
  4. Create the RAID-1 with the 1TB drives
  5. Restore drives to new Array
  • Thanks for the answer. Can you recommend software that would work with my configuration? Dec 7, 2009 at 18:34
  • Any of the standard imaging solutions would work, Symantec Ghost, CloneZilla, Acronis TrueImage.
    – Zypher
    Dec 7, 2009 at 19:51

Last time I had to do this (PERC 5/i), I had to install the Dell software (OpenManage Server Administrator) in order to grow the volume. There was no option for it in the controller setup interface - I think I even called Dell to find out what I was missing and they told me there was no other way to get it done.


If you can activate a broken mirror, and your 160GB mirror set is still intact, you can:

  • Backup the existing data.

  • Shutdown. Insert both 1TB drives. Clear all RAID metadata from the 1TB drives (delete all volumes from them via RAID bios), and create a new 1TB volume.

  • Shut down, remove one 1TB drive, and insert one 160GB drive. If possible, block-read the the 160GB drive first to ensure all blocks are readable.

  • Activate both volumes in the RAID bios to yield two visible degraded mirrored volumes.

  • Boot gparted and use it to clone the 160 to the 1TB, and expand the filesystem on the destination if desired.

  • shut down and remove the 160GB. Insert the other 1TB. Reboot and allow RAID controller to rebuild the 1TB mirror (from the new clone).

This method will avoid writing to your 160GB mirror source drives, and you will have one half of the mirror safely outside of the machine during the process... (assuming you are confident that half doesn't have undetected bad blocks...)

The biggest risk will be inflexible RAID bios that might not allow two volumes at ones, or might arbitrarily "update" the metadata on one drive to match the other, etc...

  • Actually had the time to try this process this weekend. I tried a slightly modified version. I removed the 160 GBs, put in the 1 TBs, hooked up one of the 160 GB to another SATA port, then booted into gparted. In gparted, I attempted a copy from the 160 GB boot partition to the 1 TB partition, which seems like it was working, however as far as I could tell it hanged during the copy as I gparted showed no copy progress and it ran for 9 hours without any indication of change. Anyone know if gparted shows progress during the copy? Dec 14, 2009 at 20:04
  • is the other SATA port on the RAID controller? Maybe gparted is seeing the remnants of an MBR at LBA 0 that is not the MBR being used when the RAID controller presents its volume to the OS..... But I have not had many problems with gparted. 4.83MB/s (which is 160GB/9hrs) is a reasonable rate if the source drive is fragmented or has lots of small files.
    – Joe Koberg
    Dec 23, 2009 at 17:33
  • I havent run it in a while but I "thought" it would report progress as it proceeded.
    – Joe Koberg
    Dec 23, 2009 at 17:33
  • The other SATA port was not on a RAID controller. Jan 6, 2010 at 17:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.