0

I'm trying to get a website I have hosted on AWS working with my domain bitshift.in

I have the following records:

A Record: host=@ value=54.208.24.186

A Record: host=www value=54.208.24.186

CNAME Record: host=@ value=ec2-54-208-24-186.compute-1.amazonaws.com.

CNAME Record: host=www value=ec2-54-208-24-186.compute-1.amazonaws.com.

In the AWS console I have an Elastic IP setup to point to my instance:

Elastic IP 54.208.24.186

Public DNS ec2-54-208-24-186.compute-1.amazonaws.com

https://www.whatsmydns.net/#CNAME/bitshift.in

Looks to be reporting correct values for CNAME and A records. but bitshift.in does not work. additionally pinging this IP or DNS just get stuck.

Here: https://stackoverflow.com/questions/12096312/amazon-elastic-ip-ec2 It is mentioned to configure the security groups for testing purposes. So looking ay my security groups I have:

1) Custom TCP Rule TCP 3306 sg-0d0652bb5981750d7 (awseb-e-nwnbgv3him-stack-AWSEBSecurityGroup-O6OXTPZLITSA) All traffic outbound

this looks like its my database

2) Input and output: HTTP TCP 80 0.0.0.0/0 this looks connected to my specific instance

3) Input: HTTP TCP 80 sg-02289d0c39bec2772 (awseb-e-nwnbgv3him-stack-AWSEBLoadBalancerSecurityGroup-1LNQFEN7673ZC) Output: All traffic

4) default that has all in and all out

The question is what could be wrong?

  • Nothing to do with DNS - you've got it pointing correctly. Is the webserver running on the instance? – ceejayoz Jun 22 '18 at 13:11
  • 1
    To ping your instance, you have to allow ICMP packets in security group settings. Your port 80 is not listening on this IP 54.208.24.186. Is your web server running on your instance? If your web server is running then, You can try running this command curl localhost in your ec2 instance to see if its displaying any output or not. – Azfar Ullah Khan Jun 22 '18 at 13:30
  • My instance is pointing to my elastic IP and the DNS above and says it is running in the AWS Console. bitshift-www-dev.us-east-1.elasticbeanstalk.com This is the URL my instance points to, and I can access that from the web correctly. Could it be the load balancer? I only have a single instance but I have a load balancer enabled. I've tried adding a rule (to the existing http security group) to allow all packets in and out, but still can't ping that IP: Inbound: All traffic All All 0.0.0.0/0 Outbound: All traffic All All 0.0.0.0/0 – SupaGu Jun 22 '18 at 23:22
  • further to my last comment, I see the load balancer has its own DNS: awseb-e-n-AWSEBLoa-938T82NMP45T-852869327.us-east-1.elb.amazonaws.com Should my domain actually point to this? That might be okay for a CNAME record, but what about the A record if this is the case? – SupaGu Jun 22 '18 at 23:47
0

It turns out I just needed to use the CNAME records to point to the load balance DNS, not the instance DNS.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.