Unfortunately the Hyper-V manager on my local machines returns "RPC not available" so I can't see/control my VMs. But thankfully I can RDP into the Host machine!

I need - please - to understand the Powershell command-line commands to do the following:

Mount a USB stick and make it the bootable drive for a VM I think part of the command is Set-VMDvdDrive -Path … but (a) how do I define which bootable iso (there are several) on the stick should be the active one (b) how can I force the VM to boot up from the USB (I need to recover a partition from an Acronis Back-Up) and (c) how do I then un-mount the USB stick for use with another VM? Thanks Jean

  • Wouldn’t it be easier to figure out why hyper-v manager won’t work? – Appleoddity Jun 24 '18 at 5:56
  • Well I've been trying for a year! At first my win7 machine carried on linking up so when I couldn't with win10 I was just lazy and went upstairs to the win7 but then it gave up as well as another win7 machine I have elsewhere. Believe me I have tried and tried with zero success. I even restored an Acronis image of the VMHOST that was 2 years old which didn't solve the problem (I thought I'd get back to a "vanilla" condition). I now know how to add DVD/ISO files and change the BIOS (so that the VM boots into Acronis) but I can't figure out how to see the display! Thanks Jean – Jean Rouge Jun 25 '18 at 11:42
  • The question now is how to use vmconnect.exe to see the VM at boot - again all the explanations that I've found do not take into account that the Hyper-V 2012 r2 doesn't have a GUI Jean – Jean Rouge Jun 25 '18 at 11:46
  • Thanks for the various links - finally the VMs burst into life, ran for a week and then the RPC error turned up again. For the ISOs and DVD I have figured it out thanks. What is puzzling is that the USB on the HOST doesn't appear (it used to) but I solved that by copying the iso files to a HDD location. It is probably that the USB has letter F:\ and there is an F:\ drive on the local machine. I read through the Spiceworks post mostly on time synch which I am careful to configure correctly - so far no problems there. – Jean Rouge Jun 29 '18 at 13:57

You can try this article to probably fix the RPC service - https://community.spiceworks.com/topic/2007303-hyper-v-manager-rpc-server-unavailable-rdp-cannot-verify-the-identity

First of all, you need to add the DVD drive to the VM. In case if DVD drive already exists by using Set-VMDvdDrive he can specify needed ISO. For example - Set-VMDvdDrive -VMName Test -Path E:\Acronis.iso

Regarding the bootable iso definition, you always need to specify specific ISO prior to specifying just a folder. About forcing the VM to boot up from the USB You can make by using the ling below https://www.techrepublic.com/blog/data-center/how-to-configure-hyper-v-vm-boot-order/

Un-mount the USB stick for use with another VM can be made by using Remove-VMDvdDrive cmdlet. To find the controller number, he can use Get-VMDvdDrive https://docs.microsoft.com/en-us/powershell/module/hyper-v/remove-vmdvddrive?view=win10-ps

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.