1

I'm running a Linux Server using ArchLinux, mostly for my own development needs.

It runs Arch Linux on a SW-RAID1. There's two disk drives sda and sdb, each with 3 partitions sda1-sda3, sdb1-3.

SDA1+SDB1 and SDA2+SDB2 are SW-RAID1 using dmraid / mdadm.

The system properly detects /dev/md0 and /dev/md1 and will boot from /dev/md0

On /dev/md1 there are 4 Logical Volumes created with LVM:

  • /dev/mapper/vg0-root is mapped to /
  • /dev/mapper/vg0-var is mapped to /var
  • /dev/mapper/vg0-home is mapped to /home
  • /dev/mapper/vg0-swap is mapped to /swap

And obviously the boot device, which is not in an LVM:

  • /dev/md0 is mapped to /boot

Or I should better say is supposed to be mapped to one of these. Because at boot my system isn't able to find vg0-root device. Nor any of the others.

/dev/mapper/control is the only item in /dev/mapper

When booting I get the following messages:

starting device 238
ERROR: device '/dev/mapper/vg0-root' not found. Skipping fsck.
mount: /new_root: no filesystem type specified.
You are now being dropped into an emergency shell.
sh: can't access tty: job control turned off
[rootfs ]#

I can get that repaired by running the lvm tool and then activating the volume group, which it seems to fail by default.

When I boot into the Rescue system (PXE booted minimal Debian system), that one also fails to automap the Volume Group. (i.e. the LVM volumes aren't available in /dev/mapper)

I've got the following HOOKS line in my mkinitcpio.conf:

HOOKS=(base udev autodetect modconf block mdadm_udev lvm2 filesystems keyboard fsck)

And this is the preload line in my /etc/default/grub:

GRUB_PRELOAD_MODULES="part_gpt part_msdos lvm mdraid09 mdraid1x"

Anyone got any idea what I need to configure to activate the volume group by default?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.