0

I am attempting to shadow existing RDP sessions on Windows 2012 R2 without RDS installed on a custom (not standard 3389) rdp port.

This describes how to shadow RDP in windows 2012 R2. However, when I attempt to do this using for example:

mstsc /shadow:(sessionID)  /v:(ip):(port) /control

I get computer name is invalid.

It appears although mstsc /? shows that one can specify port in the /v parameter it, in fact, does not accept that when coupled with the /shadow argument and results in error message "This computer name is invalid"

Running just mstsc v:IP:port without shadow option is successful, however, obviously this does not result in shadowing.

I have set the registry key

HKLM\SOFTWARE\Policies\Microsoft\Windows NT\Terminal Services
Shadow(DWORD) = 1

To allow shadowing with user permission.

I have also allowed multiple sessions per user in group policy which does result in allowing multiple sessions from one username.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.