0

enter image description here

We have an SSH connection to our Docker container in an Azure App Service. How do we access the file system? We have tried dir and ls. There appear to be no files or directories in the container, even though the container is actively running a live Django site.

1

I tried to recreate what you did in the Bash console and I got similar results. With no D directory being available. Screenshots

But I was able to do:

cd /

and

cd ../

And see and access parent folders. More Screenshots

Also, here's the link for the bashshell in kudu if needed: https://.scm.azurewebsites.net/DebugConsole/Default.cshtml

  • 1
    I needed cd .. It simply didn't occur to me to try. Lol. – Shaun Luttin Jun 25 '18 at 18:41
  • : Happens all the time with new ventures, so much new stuff that sometimes the simplest things slip our minds. Cool that you're exploring containers on Azure. – user9975441 Jun 26 '18 at 19:36

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.