0

Recently I added a Cloud Distribution Point and Cloud Management Gateway to our SCCM environment. The setup seems to work well, internet clients get their policies, can install software etc...

We would also like to allow internet clients to perform windows 10 feature updates through a task sequence. The task sequence works fine for intranet clients. But when an internet clients tries to start the TS, it can't download the relevant OS upgrade package.

An application package, that is referenced gets downloaded to cache fine, but when the client tries to download the upgrade package, cas.log says "No matching DP location found." for that package ID and downloading stays at 0%.

The package is distributed to the cloud DP. I have the deployment set to "Allow this task sequence to run for client on the internet" and "download all content locally before starting task sequence" since the documentation states that this is required. Pre-download is also enabled, but I don't know if that makes any difference in this situation. The client cache is also large enough.

It seems the client does not see the cloud DP as a valid location to download the upgrade package from.

Does anyone know what I might be missing? Or in which logs I can find what might be wrong?

The version of SCCM is 1802. The client is running Windows 10 Enterprise 1709, which we are trying to upgrade to 1803.

  • I really have not a lot of experience with this and could find nothing documented that supports this but did you create that cmg with 1802, or is it an older one? Because the feature of deploying upgrade task sequences via cmg is only supported since 1802 so maybe the cmg needs an upgrade. unofrtunately the whole azure stuff changed in the meantime so it's nit easy to recreate with the old manual but maybe you could try a second one for testing – Syberdoor Jun 26 '18 at 13:44
2

It works now. I did two things:

I noticed in execmgr.log, there were notifications about pre-download not working because the upgrade package was not in the same language as the client installation. (Dutch - Netherlands vs Dutch - Belgium) So I set the correct language in the properties of the package.

I deleted the package from the cloud distribution point and then distributed it again. (I had tried the redistribute button on the content locations tab of the package properties before. But that didn't work then.)

After the package was distributed again, the client started downloading.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.