0

Hello I have a really weird issue with some macs not being able to connect to 801.1x in some areas on campus. They however can connect in other places on campus. The configs for both switches are the same and we cannot figure out what is going on. No windows PC's are having this issues, the radius is windows and so is the CA. I have tried resetting the mac key chain however that did not work. I am quite unsure of where to proceed. Also the eapol logs on the macs came up with nothing. The error we are getting is that authentication failed for the Macs. WE have also reset the profile for the cert to no avail. Any help would be greatly appreciated.

Radius config (building with issues)

radius-server dead-criteria time 5 tries 1 
radius-server deadtime 5 
!
radius server Server1
 address ipv4 {IP_ADDRESS} auth-port {PORT} acct-port {PORT}
 key {KEY}
!
radius server Server2
 address ipv4 {IP_ADDRESS} auth-port {PORT} acct-port {PORT}
key {KEY}

Building that is working

radius-server dead-criteria time 5 tries 1 
radius-server host {IP_ADDRESS} auth-port {PORT} acct-port {PORT} key 7 {key}
radius-server host {IP_ADDRESS} auth-port {PORT} acct-port {PORT} key 7 {key]
radius-server deadtime 5 
0

The server was handing out a cert with no subject. Adding a subject to the cert allowed the mac to use the cert.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.