0

I just tried to make some changes in my.cnf like: innodb_buffer_pool_size, innodb_log_file_size, innodb_flush_log_at_trx_commit=0, and add "skip-name-resolve" and from that time, can't start the mariadb, even I have reverse all changes still won't work ....

I'm desperate because my shop not working, clear all of the mysql, install new, still do not start...

when i try to start or install get this errors:

Jun 27 12:28:36 server systemd[4311]: mariadb.service: Failed to change ownership of session keyring: Permission denied
Jun 27 12:28:36 server systemd[4311]: mariadb.service: Failed to set up kernel keyring: Permission denied
Jun 27 12:28:36 server systemd[4311]: mariadb.service: Failed at step KEYRING spawning /usr/bin/install: Permission denied
-- Subject: Process /usr/bin/install could not be executed
-- Defined-By: systemd
-- Support: https://www.debian.org/support
--
-- The process /usr/bin/install could not be executed and failed.
--
-- The error number returned by this process is 13.
Jun 27 12:28:36 server systemd[1]: mariadb.service: Control process exited, code=exited status=237
Jun 27 12:28:36 server systemd[1]: mariadb.service: Failed with result 'exit-code'.
Jun 27 12:28:36 server systemd[1]: Failed to start MariaDB 10.1.33 database server.
-- Subject: Unit mariadb.service has failed
-- Defined-By: systemd
-- Support: https://www.debian.org/support
--
-- Unit mariadb.service has failed.

somebody can help me ? really don't know what to do....

tried to executed /usr/bin/install -m 755 -o mysql -g root -d /var/run/mysqld, and start in safe mode... but still doesn't work

  • if you want to edit your post, do it against the formatted and readable version. – Sven Jun 27 '18 at 20:56
  • Did you look at MariaDB logfiles for errors? – Patrick Mevzek Jun 27 '18 at 22:28
  • Patrick Mevzek, have got something like this: – adjaro Jun 27 '18 at 23:12
  • Using mutexes to ref count buffer pool pages The InnoDB memory heap is disabled Mutexes and rw_locks use GCC atomic builtins GCC builtin __atomic_thread_fence() is used for memory barrier Compressed tables use zlib 1.2.8 Using Linux native AIO Using SSE crc32 instructions Initializing buffer pool, size = 128.0M Completed initialization of buffer pool Highest supported file format is Barracuda. 128 rollback segment(s) are active. Waiting for purge to start Percona XtraDB 5.6.36-82.1 started; log sequence number Dumping buffer pool(s) not yet started – adjaro Jun 27 '18 at 23:24
0

final edit: This has been reported as bug no 865870, try upgrading your packages.

apt-get update && apt-get upgrade
  • how to stop this now journalctl -f & ? ;) – adjaro Jun 27 '18 at 23:36
  • type this: kill -9 %1 – Jonas Bjork Jun 27 '18 at 23:42
  • tried this command, don't work, have the same errors... – adjaro Jun 27 '18 at 23:46
  • Did you run both commands, sequentially? You should omit the dollar sign in the beginning of the second command – Jonas Bjork Jun 27 '18 at 23:48
  • yes, no reaction – adjaro Jun 27 '18 at 23:54
0

edit: (tell your provider to) append

keyctl_chown errno 38
keyctl errno 38

to /usr/share/lxc/config/common.seccomp and restart your container.

  • sorry, I'm rookie, can you explain what need to do ? – adjaro Jun 27 '18 at 23:37
  • keyctl_chown: command not found – adjaro Jun 27 '18 at 23:48
  • It means edit the file /usr/share/lxc/config/common.seccomp and put those two lines at the end of it. – Jonas Bjork Jun 27 '18 at 23:49
  • don't have this folder and this file... – adjaro Jun 27 '18 at 23:57
  • not sure they will do this, but we will see... thanks for help, hope i will find cure for this bug quickly ;) need sleep some ;) – adjaro Jun 28 '18 at 1:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.