1

We have a server with Proxmox installed with Debian, it's an dedicated server (sda). The VM's are being backed up every night on a CEPH disk (sdb). After an reboot of the dedicated, the ext4 drive from the dedicated server had a broken superblock.

In order to restore the ext4 drive I looked up the restorable superblocks with:

sudo mke2fs -n /dev/sda

restorable superblocks

But when I tried to restore the superblock to the sda drive I accidentally tried to restore the superblock from (sda) to the network CEPH drive (sdb) with the following command:

sudo e2fsck -b 32768 /dev/sdb

Now the CEPH disk is unreadable.

Is there any solution to restore of get the data from the CEPH disk? I am not very experienced with server stuff. And if I am missing crucial information let met know.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.