0

I am learning to handle iptables when but I had to port forward over a NAT host machine to a server on a VM running CentOS 6.9. Host machine is running Kubuntu 18.04.

After trying some iptable rules and ufw (which I promptly disabled after), yum on the VM insists on picking ipv6 mirrors. I have tried new VMs but it still doesn't work.

I installed iptables-persistent on host and despite running sudo iptables -F it seems that the rules are not flushed from /etc/iptable/rules.v4 Now I am worried if deleting the entire file would result in instability with my host machine and doesn't solve it at all.

2 Answers 2

0

I solved the issue by uninstalling iptables-persistent from the host machine and restarting the machine. One of the rules that I have added while experimenting must have tampered with the access. I have also deleted /etc/iptables/rules.v4

0

YUM seems to prefer IPv6 over IPv4 when the former is available. You can set

ip_resolve=4

in [main] section of /etc/yum.conf to force resolution to only try IPv4 (A-records).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.