0

I've accidentally blocked incoming connections on my server in EC2 and now I can't connect to the instance. I've launched a separate instance and mounted the root volume from the original instance on top of it to copy over files. Is there any way to disable Windows Firewall on the original instance by booting into a boot disk or modifying something externally?

2

Did you close only RDP or you think you disabled all traffic? If you disabled only RDP try to establish remote Powershell session to your instance (of course, you need to open needed ports on AWS Security Group) and disable firewall by command.

If you cut of all traffic, you can mount drive to another instance, open Registry editor and mount registry hive from file (should be under HKEY_LOCAL_MACHINE\SYSTEM: %windir%\system32\config\SYSTEM) and than navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Parameters\FirewallPolicyStandardProfile from there, you should see DWORD called EnableFirewall, put value to 0, and that should be it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.