0

I am upgrading kernel (Red Hat) from 6.7 to 6.9 with Amazon AMI and when I am installing Oracle through puppet I am getting this pre-requisite error.

Error: Execution of '/usr/bin/yum -d 0 -e 0 -y install gcc-c++' returned 1: Error: Package: glibc-2.12-1.107.el6_4.2.i686 (Repo)
           Requires: glibc-common = 2.12-1.107.el6_4.2
           Installed: glibc-common-2.12-1.209.el6_9.2.x86_64 (installed)
               glibc-common = 2.12-1.209.el6_9.2
           Available: glibc-common-2.12-1.107.el6_4.2.x86_64 (Repo)
               glibc-common = 2.12-1.107.el6_4.2
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
Error: /Stage[main]/Oracledb::Prereq/Package[gcc-c++]/ensure: change from purged to present failed: Execution of '/usr/bin/yum -d 0 -e 0 -y install gcc-c++' returned 1: Error: Package: glibc-2.12-1.107.el6_4.2.i686 (Repo)
           Requires: glibc-common = 2.12-1.107.el6_4.2
           Installed: glibc-common-2.12-1.209.el6_9.2.x86_64 (installed)
               glibc-common = 2.12-1.209.el6_9.2
           Available: glibc-common-2.12-1.107.el6_4.2.x86_64 (Repo_New)
               glibc-common = 2.12-1.107.el6_4.2
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
Error: Execution of '/usr/bin/yum -d 0 -e 0 -y install elfutils-libelf-devel.x86_64' returned 1: Error: Package: elfutils-libelf-devel-0.152-1.el6.x86_64 (Repo
           Requires: elfutils-libelf(x86-64) = 0.152-1.el6
           Installed: elfutils-libelf-0.164-2.el6.x86_64 (installed)
               elfutils-libelf(x86-64) = 0.164-2.el6
           Available: elfutils-libelf-0.152-1.el6.x86_64 (Repo)
               elfutils-libelf(x86-64) = 0.152-1.el6
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
Error: /Stage[main]/Oracledb::Prereq/Package[elfutils-libelf-devel.x86_64]/ensure: change from purged to present failed: Execution of '/usr/bin/yum -d 0 -e 0 -y install elfutils-libelf-devel.x86_64' returned 1: Error: Package: elfutils-libelf-devel-0.152-1.el6.x86_64 (Repo)
           Requires: elfutils-libelf(x86-64) = 0.152-1.el6
           Installed: elfutils-libelf-0.164-2.el6.x86_64 (installed)
               elfutils-libelf(x86-64) = 0.164-2.el6
           Available: elfutils-libelf-0.152-1.el6.x86_64 (Repo)
               elfutils-libelf(x86-64) = 0.152-1.el6
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
0

You have installed two (or maybe more?) custom yum repos on this system, named "Repo" and "Repo_New". These repos appear to be version locked to EL 6.4. You should remove these custom repos and replace them with the originals, or fix them.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.