0

Running Ubuntu on AWS to do a proof of concept for staytus. I am super green and have waded through most of my issues to get to this point.

staytus tutorial is what I've been following, and perhaps it's my lack of skills, but I've found it to be left wanting.

stuff I've had to do beyond the tutorials recommendations to continue through the installation :

CREATE DATABASE `staytus` CHARSET utf8mb4 COLLATE utf8mb4_unicode_ci;
CREATE USER `staytus`@`127.0.0.1` IDENTIFIED BY '*********';
GRANT ALL ON `staytus`.* TO `staytus`@`127.0.0.1`;

staytus:

Ruby 1.99 was installed did this and got ruby 2.4

sudo apt-add-repository ppa:brightbox/ruby-ng
sudo apt-get update
sudo apt-get install ruby2.4
sudo apt-get install ruby2.4-dev

need to update gemfile to show ruby '2.4.4' and then gem install bundler

last error I got:

ubuntu@ip-172-31-26-129:/opt/staytus/staytus$ sudo -u staytus procodile start --dev
/var/lib/gems/1.9.1/gems/procodile-1.0.19/lib/procodile/cli.rb:160: warning: else without rescue is useless
/usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require': /var/lib/gems/1.9.1/gems/procodile-1.0.19/lib/procodile/cli.rb:57: syntax error, unexpected keyword_do_block, expecting keyword_end (SyntaxError)
...ort_by { |k,v| k.to_s }.each do |method, options|
...                               ^
/var/lib/gems/1.9.1/gems/procodile-1.0.19/lib/procodile/cli.rb:57: syntax error, unexpected '|', expecting '='
/var/lib/gems/1.9.1/gems/procodile-1.0.19/lib/procodile/cli.rb:144: syntax error, unexpected keyword_do_block, expecting keyword_end
          instances.each do |instance|
                           ^
/var/lib/gems/1.9.1/gems/procodile-1.0.19/lib/procodile/cli.rb:145: syntax error, unexpected tSTRING_BEG, expecting keyword_do or '{' or '('
            puts "Started".color(32) + " #{inst...
                  ^
/var/lib/gems/1.9.1/gems/procodile-1.0.19/lib/procodile/cli.rb:155: syntax error, unexpected keyword_do_block, expecting keyword_end
...upervisor(@config, @options) do |supervisor|
...                               ^
/var/lib/gems/1.9.1/gems/procodile-1.0.19/lib/procodile/cli.rb:162: syntax error, unexpected keyword_end, expecting $end
        from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
        from /var/lib/gems/1.9.1/gems/procodile-1.0.19/bin/procodile:16:in `<top (required)>'
        from /usr/local/bin/procodile:23:in `load'
        from /usr/local/bin/procodile:23:in `<main>'

I've seen this block of error prior when trying to do installations, but they aren't exactly google able. Thank you for the help in advance

0

Use this command which should fix your issue

gem install procodile

I had the same issue. The above fixed the issue

  • 2
    Can you elaborate, why this has fixed your issue? – pacey Oct 2 '18 at 8:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.