0

Similar to this question: Widows server 2008, iis7. Unable to set up SSL for public use. Possible port issue

I've recently set up a SSL certificate on a website. When I tried to access the site in my browser using HTTPS I get a timeout error, but HTTP works fine. What could be the problem?

What I've tried so far to fix this:

  • I added the registry keys for TLS 1.1 and TLS 1.2, for both Server a Client, with values DisabledByDefault = 0 and Enabled = 1 (and restarted the server afterwards).
    • There was no registry key for TLS 1.0.
  • I checked the firewall's rule "World Wide Web Services (HTTPS Traffic-In)"; it was already enabled.
  • I was able to go to the website from the server using HTTPS, and other than a warning about the certificate being issued to a different domain (which I guess it's because I used "localhost"), I had no issues.
  • I opened a command-line window on the server and executed the command netstat -ano | find /i "443"; I got the following:

    TCP    0.0.0.0:443            0.0.0.0:0              LISTENING       4
    TCP    [::]:443               [::]:0                 LISTENING       4
    
  • I used the command line to trace the route to the site using port 80 and then port 443. When checking port 443, at the last hop (and each hop until reaching the maximum), I got this:

    9       *       *       *       Request timed out.
    
  • I used portqry to check the status of port 443 on the server, and I got this:

    TCP port 443 (https service): FILTERED
    
0

Our web hosting provider had port 443 closed by default. It was necessary that we requested for them to open that port. After doing that, the site loaded normally using HTTPS.

  • 1
    They did what? Are you sure they're even competent enough to have your business? That's completely ridiculous! – Michael Hampton Aug 10 '18 at 14:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.