0

We're experiencing 100% CPU usage from the process Microsoft.Identity.Health.AadSync.MonitoringAgent.Startup on our Domain Controllers that have Azure AD Connect installed, since yesterday.

According to this discussion, an official from Microsoft says that the problem is due to an incompatibility with Microsoft .NET Framework 4.7.2 .Net Framework - KB4054542 (Server 2012), KB4054566 (Server 2012 R2) and KB4054590 (Server 2016), but unfortunately for us, on our 2012 R2 servers, KB4054566 failed to install so can't be uninstalled. And a related update KB4340006 that did successfully install, which is the one I think caused our problems, cannot be uninstalled either.

I know plenty of other people are experiencing this issue... what's the best action to take before Microsoft releases a new version of Azure AD Sync Monitor?

  • Restarting the AzureADConnectHealthSyncMonitor service drops CPU usage right down to 1-2%, without having to remove any Windows Updates... but a short while later, CPU usage gradually goes back up to 99-100%. – Matty Brown Jul 13 '18 at 11:24
  • I've disabled "Azure AD Connect Health Sync Monitoring Service" until a proper fix is available from Microsoft. Must remember to set it back to "Automatic (Delayed Start)". – Matty Brown Jul 13 '18 at 12:46
1

UPDATE: Follow the link below, Microsoft released 1.1.880.0 on 8/1/2018 that resolves the issue.

You can either look for some of the recent Windows Updates described in this article How to Fix microsoft.online.reporting.monitoringagent.startup High CPU or you can set the Azure AD Connect Health Sync Monitoring Service to manual until Microsoft releases an updated client to resolve the issue, then just remember to set it back to Automatic.

1

A new version of Azure AD Connect (1.1.880.0) has been released, which can be downloaded here.

According to the release notes, one of the fixed issues is "Fixed a bug where the AAD Connect server would show high CPU usage after upgrading to .Net 4.7.2".

Having installed the update, I found that the services I previously disabled are now set back to Automatic (Delayed) without having to remember to go back and do this myself.

0

Having the same issue on a Server 2008 R2 box after the .NET 4.7.2 update this week. Have worked with Matty Browns suggestion of disabling the service until the issue is worked through by Microsoft (Updates or ADConnect Utility).

protected by Community Jul 26 '18 at 16:06

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.