4

I manage several Windows 2012 based DHCP servers and on one of these I came across a peculiarity that I cannot explain and do not know where to correct:

In DHCP manager*, expand [server name], then IPv4, policies (or [network], then policies). Create a new or edit an existing policy and in the conditions tab, add or edit a condition.

The expected behaviour is that you are presented with a dialog where you can pick

  • a criterion (vendor class, user class, MAC address, etc.)
  • an operator (equals, not equals)
  • a value field**
  • a prepend wildcard checkbox**
  • an append wildcard checkbox**

At least this is the case with the majority of my servers. On one single server, however, the "prepend wildcard" checkbox is always disabled:

enter image description here

Q: How come? What does this signify? Is there a problem or misconfiguration? Of course, to my knowledge all servers are (or should be) mostly identical as far as updates and configurations are concerned ...


* All options, dialog labels etc. are translated back from the German version, hence I'm sorry if there is no perfect match with the English version

** The form has different fields when picking relay agent info as critrion, but that is irrelevant for this question

1
3
+25

It looks like you are managing a Windows Server 2012 DHCP server remotely from a Windows Server 2012 R2 server. Prepend wildcard was introduced in Windows Server 2012 R2 and is not available in Server 2012. You see the option because the R2 DHCP console supports that feature. Its grayed out because the 2012 server does not. See the below article regarding DHCP in Server 2012 R2.

Windows Server 2012 R2- Enhancing DHCP policies and DNS registrations in DHCP server

  • Now, you can attach wildcards at the beginning of condition values as well. This will allow you to identify clients whose attribute value ends with a particular set of characters. And now you can use wildcards with relay agent information based criteria as well.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.