0

I've just installed OpenVAS in Ubuntu Server inside VirtualBox which was installed without GUI. The only way to access this box is via SSH.

Once OpenVAS installation completed, I tried to access it via Web Browser from my host PC.

Unfortunately it didn't work. I quickly fire up tcpdump and noticed that SYN packet was responded with RST immediately. Something not right.

user@ubuntu:~$ sudo tcpdump port 9392
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on enp0s3, link-type EN10MB (Ethernet), capture size 262144 bytes
07:53:01.322339 IP MyPC.62954 > ubuntu.9392: Flags [S], seq 2754395230, win 8192, options [mss 1460,nop,wscale 8,nop,nop,sackOK], length 0
07:53:01.322368 IP ubuntu.9392 > MyPC.62954: Flags [R.], seq 0, ack 2754395231, win 0, length 0
07:53:01.322796 IP MyPC.62955 > ubuntu.9392: Flags [S], seq 1949529448, win 8192, options [mss 1460,nop,wscale 8,nop,nop,sackOK], length 0
07:53:01.322814 IP ubuntu.9392 > MyPC.62955: Flags [R.], seq 0, ack 1949529449, win 0, length 0

Therefore, I check the port status and found out that it's only listening to localhost only or 127.0.0.1

user@ubuntu:~$ sudo ss -antp
State          Recv-Q     Send-Q     Local Address:Port    Peer Address:Port                                                                 
LISTEN         0          128            127.0.0.1:9390         0.0.0.0:*      users:(("openvasmd",pid=1693,fd=4))                           
LISTEN         0          128            127.0.0.1:80           0.0.0.0:*      users:(("gsad",pid=1732,fd=5))                                
LISTEN         0          128            127.0.0.1:9392         0.0.0.0:*      users:(("gsad",pid=1718,fd=5))          

Any idea how to change the config so that I can access OpenVAS remotely?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.