0

Our Devs are trying to do a "push" and it is failing on a single IIS server (running Windows Server 2012 R2) because the push is unable to stop the WWW Publishing Service (W3SVC). We have been rebooting the Svr2012R2 VM as a workaround fix to the issue, but need to get to the heart of the problem.

I read here that the issue could be linked to SvcHost.exe process, but am unsure at this point. Any help or feedback appreciated, thank you.

  • Svchost is just a generic container for launching services. – Greg Askew Jul 17 '18 at 14:49
  • What methods or commands are they using to stop the service? – SturdyErde Jul 17 '18 at 19:22
  • I've used 'net stop W3SVC -force' to try and stop the service, but once the service has failed to stop it does not work. – KidACrimson Jul 18 '18 at 18:43
  • Apparently just re-configuring the App Pools fixed it, I've been told. Thanks, all. – KidACrimson Jul 24 '18 at 15:47
0

This is solved by installing updates, apparently there was some issue with one of the recent Windows updates:

https://support.microsoft.com/en-us/help/4345424/improvements-and-fixes-windows-8-1-and-server-2012-r2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.