1

On Leap 15, I have installed the latest version of ejabberd, and have tried to install jwchat. But ejabberd now uses yml files, and none of the jwchat tutorials use yml files, but I have tried to make the connection. My question is what in the setup (using ejabberd as the server, and not apache) determines the web url for the chat? site:5280/web/jwchat/index.html gives me a 404. Some tutorials have a line that I think would translate at "/web": mod_http_fileserver but this does not seem to matter. Since jwchat is in /var/lib/ejabberd/www/jwchat, where does the "web" in the URL come from? I get nothing in the webaccess.log file, and the main log file says it accepts my connection to 5280. How do I get jwchat to serve pages?

0

With this example configuration:

listen:
  -
    port: 5280
    module: ejabberd_http
    request_handlers:
      "/jjj": mod_http_fileserver

modules:
  mod_http_fileserver:
    docroot: "/var/lib/ejabberd/www/jwchat"

Let's imagine you have installed JWChat in the path you mentioned. Then, the local file at location

/var/lib/ejabberd/www/jwchat/index.html

will be provided when you visit the URL:

http://localhost:5280/jjj/index.html

  • Thank you, thank you. It would be great if there were some comments in the yml file about this. But, it is still not quite working. I have it on a host with a dynamic dns address. If I add its internal ip address to the yml file, and use – BJ TN Jul 19 '18 at 13:34
  • But, it is still not quite working. I can log in, and the windows pop up. But I do not see any of the people using xmpp clients. Nor do I see buddies. Using pidgin, I did not have to "add" them to see them. All users are visible to everyone. Any ideas? Thanks again. – BJ TN Jul 19 '18 at 13:49
  • I tried both bind and polling, but still no window content. I also tried adding users, but they get no authorization requests. – BJ TN Jul 19 '18 at 15:24
  • Now I get service unavailable message in the pop up window. Do I need to comment out the ejabberd_service stanza in ejabberd.yml? If so, how should it be configured for jwchat? – BJ TN Jul 19 '18 at 18:09
  • The docs say "If HTTP Polling is enabled, it will be available at server:port/http-poll. " So in this case, how does one access the jwchat pages? localhost:5280/http-poll/web/index.html does not work. – BJ TN Jul 19 '18 at 18:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.