0

getting errors after following this tutorial: https://www.linode.com/docs/websites/cms/set-up-dns-services-on-cpanel/

DNS servers responded   
ERROR: One or more of your nameservers did not respond:
The ones that did not respond are:
162.159.27.72 162.159.26.99 162.159.24.25 162.159.24.39 162.159.25.129

I could use the nameservers listed below to performe recursive queries. It may be that I am wrong but the chances of that are low. You should not have nameservers that allow recursive queries as this will allow almost anyone to use your nameservers and can cause problems. Problem record(s) are:

162.159.26.99
162.159.24.39
162.159.24.25
162.159.27.72
162.159.25.129

what have I done so far:

1) add name servers at my domain registrar

ns1.example.com
ns2.example.com
ns1.linode.com
ns2.linode.com
ns3.linode.com
ns4.linode.com
ns5.linode.com

2) update named.conf.options file

3) add a slave zone

nano /etc/bind/named.conf.options

options {
        directory "/var/cache/bind";

        // If there is a firewall between you and nameservers you want
        // to talk to, you may need to fix the firewall to allow multiple
        // ports to talk.  See http://www.kb.cert.org/vuls/id/800113

        // If your ISP provided one or more IP addresses for stable
        // nameservers, you probably want to use them as forwarders.
        // Uncomment the following block, and insert the addresses replacing
        // the all-0's placeholder.

        // forwarders {
        //      0.0.0.0;
        // };

        //========================================================================
        // If BIND logs error messages about the root key being expired,
        // you will need to update your keys.  See https://www.isc.org/bind-keys
        //========================================================================
        dnssec-enable yes;
        dnssec-validation yes;
        dnssec-lookaside auto;

        auth-nxdomain no;    # conform to RFC1035
        listen-on-v6 { any; };


        allow-transfer {
     104.237.137.10;
     65.19.178.10;
     75.127.96.10;
     207.192.70.10;
     109.74.194.10;
     2600:3c00::a;
     2600:3c01::a;
     2600:3c02::a;
     2600:3c03::a;
     2a01:7e00::a;
 };
 also-notify {
     104.237.137.10;
     65.19.178.10;
     75.127.96.10;
     207.192.70.10;
     109.74.194.10;
     2600:3c00::a;
     2600:3c01::a;
     2600:3c02::a;
     2600:3c03::a;
     2a01:7e00::a;
 };

        // Do not make public version of BIND
        version none;
};

dig

; <<>> DiG 9.10.3-P4-Debian <<>> axfr @162.159.27.72 revelhost.net
; (1 server found)
;; global options: +cmd
; Transfer failed.
13
  • What kind of response do you get from the slave servers if you query them directly (using eg dig)? – Håkan Lindqvist Jul 20 '18 at 21:14
  • check out the updated question with dig – velvetInk Jul 21 '18 at 0:43
  • That doesn't look like a representative query for the problem you were describing. Something like dig @162.159.27.72 example.com +norec, maybe? – Håkan Lindqvist Jul 21 '18 at 0:52
  • check now question updated – velvetInk Jul 21 '18 at 1:05
  • Do you mind explaining what you are trying to accomplish? Did you remember to create the A registries in your registrar for the NS domains (ns1.example.com and ns2.example.com)? Also the file is /etc/named.conf not named.conf.options and you could check everything is ok with named-checkconf /etc/named.conf – Leo Jul 21 '18 at 3:10
0

In the discussion of the question in comments and chat, it turned out that the named logs said things such as

client 104.237.137.10#45797 (example.com): zone transfer 'example.com/AXFR/IN' denied

After further questions about that the named config actually contained, it turned out that the allow-transfer directive on the global-level (inside options) shown in the question was actually overridden on the zone level (inside the relevant zone) to not allow these slave nameservers.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.