0

We're having a problem uploading a disk image to an iDRAC5 to boot a troubled server using the Virtual Media feature.

Here is the scenario:

  • Machine 1 and Machine 2 are far away.

  • Machine 2 is accessed via SSH.

  • All VMCLI tool connections to Machine 1's iDRAC5 are done directly from Machine 2.

  • All SSH to Machine 1's iDRAC5 are done directly from Machine 2.

  • ALL HTTPS to Machine 1's iDRAC5 are done through Machine 2 via tunnelling or SOCKS proxy. We attempted running browsers from Machine 2 X11 forwarding, but there were significant configuration issues.

  • We need to boot Machine 1 to run DSET. All of the below are run via a remote connection to Machine 2.

  • Machine 1: A powered on, but nonfunctioning, Dell server with an Integrated Dell Remote Access Controller (iDRAC) card. We know via an on-site check that Machine 1's RAID card has likely failed, all HD leds are dark. There may be other problems. Our support service needs us to run the Dell System E-Support Tool (DSET), but at this moment using Virtual Media seems to be the only way. An attempt to boot a live CD from an optical drive failed.

  • Machine 2: A Dell server with a direct ethernet connection to Machine 1. Scientific Linux 6.11 (SL is derived from CentOS). We can SSH to Machine 1's iDRAC5 card and access the Machine 1 iDRAC5 web interface.

Web interface: We've tried uploading the disk image using the web interface. It times out between 20% and 50% of the upload. The console feature does not work. We've tried current versions of Firefox, Chrome, and Konqueror. We're currently creating a CentOS 5 virtual machine to see if older versions will work.

VMCLI to iDRAC5: All of the Virtual Media Command Line tools currently fail. I've pasted the results from several versions of virtual media command line tool(racvmcli5, vmcli, iVMCLI) below.

SSH to iDRAC5 RACADM This works. We can ssh to the iDrac5 card from the command line, and I've pasted the configuration information from racadm.

### racvmcli version 1.0
racvmcli5 -v
racvmcli version 1.0
Copyright (c) 2007 Dell, Inc.
All Rights Reserved

racvmcli5 -r 10.109.130.157:3669 -c openSUSE-Tumbleweed-GNOME-Live-x86_64-Current.iso -u root -p XXXXX


racvmcli: connecting(1)..
Failed to initialize SSL layer
racvmcli: unable to connect to '10.109.130.157:3669'
#####iDRAC Virtual Media Command Line Interface. Version: 3.0.0.3
vmcli -v

iDRAC Virtual Media Command Line Interface. Version: 3.0.0.3
Copyright (c) 2016 Dell, Inc. All rights reserved.
OpenSSL 1.0.2k  26 Jan 2017

vmcli -v -r 10.109.130.157:3669 -c openSUSE-Tumbleweed-GNOME-Live-x86_64-Current.iso -u root -p XXXXX

Security Alert: Certificate is invalid - self signed certificate
Continuing execution. Use -S option for vmcli to stop execution on certificate-related errors.
 Failed to acquire credentials.
Terminating
######Virtual Media Command Line Interface Version 2.9
iVMCLI -v

Virtual Media Command Line Interface Version 2.9
Copyright (c) Dell Inc., 2010
All Rights Reserved



iVMCLI -r 10.109.130.157 -u root -c openSUSE-Tumbleweed-GNOME-Live-x86_64-Current.iso -p XXXXXX
Virtual Media Command Line Interface Version 2.9
Copyright (c) Dell Inc., 2010
All Rights Reserved


Error (7):Could not connect to Server or  Insufficient privilege to create temporary files in the current folder.You might not have administrator privileges or the current folder is Read-only.
############### RACADM getsysinfo
$ racadm getsysinfo

RAC Information:
RAC Date/Time           = Wed Jul 25 22:28:48 2018
Firmware Version        = 1.65
Firmware Build          = 12.08.16
Last Firmware Update    = Mon Jul 23 01:38:57 2018


Hardware Version        = A03
Current IP Address      = 10.109.130.157
Current IP Gateway      = 10.109.130.1
Current IP Netmask      = 255.255.255.0
DHCP Enabled            = 0
MAC Address             = aa:bb:cc:dd:ii:jj
Current DNS Server 1    = 208.67.220.220
Current DNS Server 2    = 8.8.8.8
DNS Servers from DHCP   = 0
Register DNS RAC Name   = 0
DNS RAC Name            = rac-ZZZZZZZ
Current DNS Domain      =


System Information:
System Model            = PowerEdge R9XY
System Revision         = [N/A]
System BIOS Version     = 1.2.0
BMC Firmware Version    = 2.27
Service Tag             = ZZZZZZZ
Express Service Tag     = 25679835318
Host Name               = MachineOne.nonceplace.com
OS Name                 =
Power Status            = ON


Watchdog Information:
Recovery Action         = None
Present countdown value = 15 seconds
Initial countdown value = 15 seconds


Embedded NIC MAC Addresses:
NIC1 Ethernet           = aa:bb:cc:ee:ff:gg
NIC2 Ethernet           = aa:bb:cc:ee:ff:hh

EXTRACT FROM RACADM GETTRACELOG

racadm gettracelog

Record:      271
Date/Time:   Jul 25 18:17:47
Source:      virmediad[391]
Description: VM: attaching because client is connected (auto attach)
-------------------------------------------------------------------------------
Record:      272
Date/Time:   Jul 25 18:17:47
Source:      kernel
Description: can not open device because it is already open
-------------------------------------------------------------------------------
Record:      273
Date/Time:   Jul 25 18:17:47
Source:      virmediad[391]
Description: ssn_op: idx_from_sid = 0
0

All connections to Machine 1 are done remotely through Machine 2 via tunnelling or SOCKS proxy

From what I understand you try to send the ISO to machine1 idrac through socks/tunnel ? that's probably the problem.

I would rather:

  • upload the ISO to machine2
  • take control over machine2
  • send iso from machine2 local disk to machine1
  • Sorry, I should have put a bit more info about this in the original post. This is indeed the case. We've downloaded the iso to Machine 2 and all of the VMCLI tools are being run from Machine 2. We've tried running browsers directly from Machine 2 (via X) with both Firefox and Konqueror, but the iDRAC page shows up malformed. – edward estlin Jul 27 '18 at 12:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.