2

Recently, trying to import a BACPAC to an Azure SQL Server using SSMS (SQL Server Management Studio) has been failing with the following error:

enter image description here

Failed to connect to server ___.database.windows.net. (Microsoft.SqlServer.Smo) Login failed for user 'NT AUTHORITY\ANONYMOUS LOGON'. (Microsoft SQL Server, Error: 18456)


The steps I have used to import the BACPAC are as follows:

  1. Connect to server in SSMS using my AzureAD credentials.
  2. Right click on Databases and choose "Import Data-tier application"
  3. Select my BACPAC file and click next.
  4. Leave default settings for S2 Azure DB and click next.
  5. Error appears before it gets to the Summary page.

The above steps have worked great for the last 2 years, and just recently stopped working. I've tried on 2 different computers, different networks, and different versions of SSMS (that have worked find in the past) but they all still fail.

Using a regular SQL server password login (non AzureAD account) imports the BACPAC successfully, as does importing via Azure Portal.

Any idea what could be causing this issue?

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.