0

I installed squid on Kali linux, configured my browser to send whole traffic through squid. However, squid doesn't consider localhost traffic. Actually, I run this command to check log file while I'm browsing:

tail -f /var/log/squid/access.log

It considers all traffics except localhost one, and when I go to localhost in my browser, the below line is submitted in the log file by squid:

127.0.0.1 TCP_TUNNEL/200 39 CONNECT www.google.com:443 - HIER_DIRECT/172.217.21.196 

I don't know why it submits google when I go to localhost. I configured squid using Install Squid.

1

Maybe you should configure your browser correctly, if you use firefox, simply go to Options --> General --> Network Proxy --> Settings , and in the No Proxy for section, clear localhost, 127.0.0.1.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.