I have three hyper-v servers on an AD domain, which replicate between themselves nicely. I have two other hyper-v servers which are separate, in their own workgroup, they are being built in my personal environment for deployment in a temporary environment for a couple of weeks.

The two workgroup servers replicate their VMs between themselves using certificate auth. This is working fine.

Each VM in the workgroup hypervisors used to have extended replication to a server in my personal environment (where backups happen), again using certificate auth. This no longer works. I removed extended replication temporarily and when I came to re-apply I can no longer get past the "specify replica server" screen on the Extended replication wizard. What happens is I enter the name of the target replica server, click next and then the "Verifying configuration..." dialogue flashes on and off until it's manually stopped. (I've left it over night, to find it doing the same thing in the morning) Sometimes, the progress bar gets almost to the end, other times it doesn't even appear before the dialogue flashes off and seemingly starts doing whatever it was doing again.

I've tried to start the replication at the hyper-v command line and get a "WinRM client cannot process the request..." There is some stuff about this only applying to Kerberos (I'm using certificate), make sure you use HTTPS (I am doing) and it the target must be added to trusted hosts (it is).

There are no firewalls switched on. As far as I'm aware, I've not made any changes. I believe that the problem is the workgroup machines, because the flashing dialogue box behaviour starts when searching for any machine which isn't one or other of the two in the workgroup.

The two hyper-v machines sit on their own subnet, with an RRAS router to get to the internet. The hyper-v machine they should replicate to has a nic in both networks and this is explicity specified in hosts on both workgroup machines.

Any ideas anyone? I have found not a single thing on the Internet about this problem...

It's maybe too late for you but it can still help another reader. I've encounter this issue and solved it by removing the replication server from the trusted-host list. (I was in a full Workgroup server configuration)

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.