0

I've seen too many articles how to install and configure squid but most of them are written how to configure it in the local network. I'm going to create public forward proxy server, so:

  • I have installed squid on Linode Centos 7 instance,
  • Service is running
  • Squid uses 3128 port and it is open from outside the network

Now, from my home, I try to change proxy settings in Firefox but I have still my home IP.

  1. I have written acl all src all to the top of your ACL list.
  2. I have changed http_access deny all to http_access allow all
  3. I've tested and 3128 port is accessible from my home PC

Is there anything else that I should do? have I done anything wrong?

0

Your problem is probably in this step:

Now, from my home, I try to change proxy settings in Firefox but I have still my home IP.

If the server still shows your home IP, it seems Firefox doesn't use your proxy. Try to stop your proxy and see whether Firefox complains that the proxy is unavailable.

If firefox does use your proxy, try this setting in squid.conf

forwarded_for off
  • Everything seems well in Firefox. I've tested this config, but does not works :( – grep Aug 6 '18 at 21:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.