0

I'm trying to deploy a gluster cluster with 12 nodes with 10 TB each one, but when I create the volume each brick is created with only 50GB, it must have the entire disk space i suppose. This is my config:

Disk config in each node:

NAME            MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
sda               8:0    0   9,1T  0 disk 
└─sda1            8:1    0   9,1T  0 part /bricks/brick1

Gluster volume info:

Volume Name: vol01
Type: Distributed-Replicate
Volume ID: 70de6c08-e133-406e-99b0-7284be67cf5f
Status: Started
Snapshot Count: 0
Number of Bricks: 6 x 2 = 12
Transport-type: tcp
Bricks:
Brick1: gfs01:/glusterfs/distributed
Brick2: gfs02:/glusterfs/distributed
Brick3: gfs03:/glusterfs/distributed
Brick4: gfs04:/glusterfs/distributed
Brick5: gfs05:/glusterfs/distributed
Brick6: gfs06:/glusterfs/distributed
Brick7: gfs07:/glusterfs/distributed
Brick8: gfs08:/glusterfs/distributed
Brick9: gfs09:/glusterfs/distributed
Brick10: gfs10:/glusterfs/distributed
Brick11: gfs11:/glusterfs/distributed
Brick12: gfs12:/glusterfs/distributed
Options Reconfigured:
transport.address-family: inet
nfs.disable: on
performance.client-io-threads: off

Brick's volume detail (only 2 of them, rest have same config):

Brick                : Brick gfs01:/glusterfs/distributed
TCP Port             : 49152               
RDMA Port            : 0                   
Online               : Y                   
Pid                  : 12308               
File System          : xfs                 
Device               : /dev/mapper/centos-root
Mount Options        : rw,relatime,attr2,inode64,noquota
Inode Size           : 512                 
Disk Space Free      : 48.4GB              
Total Disk Space     : 50.0GB              
Inode Count          : 26214400            
Free Inodes          : 26152769            

Brick                : Brick gfs02:/glusterfs/distributed
TCP Port             : 49152               
RDMA Port            : 0                   
Online               : Y                   
Pid                  : 11446               
File System          : xfs                 
Device               : /dev/mapper/centos-root
Mount Options        : rw,relatime,attr2,inode64,noquota
Inode Size           : 512                 
Disk Space Free      : 48.4GB              
Total Disk Space     : 50.0GB              
Inode Count          : 26214400            
Free Inodes          : 26152770 

Client mount point (50*12=300GB):

gfs01:/vol01                              300G    13G  288G   5% /mnt/glusterfs

Any idea? Am I missing something?

1

It seems that the disk for the brick is mounted at /bricks/brick1. But you created the volume based on a different directory for the bricks, namely gfs01:/glusterfs/distributed.

You should probably create a new volume, like this:

# gluster volume create lotsofdata \
  replica 2 \
  gfs{01,02,03,04,05,06,07,08,09,10,11,12}:/bricks/brick1/data

# gluster volume start lotsofdata

Make sure that /bricks/brick1 is mounted automatically (through /etc/fstab or a systemd.mount). You should then be able to mount the new volume called lotsofdata and copy the contents from vol1 to there.

Currently your vol1 is using the space from the /dev/mapper/centos-root logical volume. So you will want to remove vol1 and all of the /glusterfs/distributed directories.

| improve this answer | |
  • Thank you very much! It works! I can't believe I didn't notice that! – six2dez Aug 9 '18 at 10:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.