1

I have a Zabbix Proxy running on Raspien. The version of proxy is 3.0.7 and the version of server is 3.4.11.

The proxy communicates with the server under Administration -> Proxies but its not running active checks.

When I tail the logs on the server, we get cannot send list of active checks to "10.0.0.201": host Exchange01 not found.

I also get failed to update local proxy configuration copy: invalid field name "items.jmx_endpoint".

The hostname is correct in all config files, I jsut cant seem to get this to work. For Exchange01, I have the Template OS Windows assigned. The ZBX icon wont go green, it stays grey.

Any ideas what could be causing this?

3

You are running an unsupported combination. Configuration changes from your server cannot be synchronised to the proxy, thus the freshly added or changed host is not - and will be not - known to the proxy.

| improve this answer | |
  • I thought as much. Which version of proxy is compatible? I thought I had installed 3.4 proxy but apparently not. When I upgrade from the proxy I have the latest version. – dynmatt Aug 8 '18 at 15:02
  • 1
    As per the compatibility page in the documentation, proxy and server must be of the same major version. Earlier you specified that "The version of proxy is 3.0.7 and the version of server is 3.4.11". – Richlv Aug 8 '18 at 19:27
  • I had thought I installed 3.4 the URL i got the package from is repo.zabbix.com/zabbix/3.4/debian/pool/main/z/zabbix-release/… – dynmatt Aug 10 '18 at 17:32
2

The hostname that the Zabbix agent is configured with must match the hostname set up in the Zabbix server. This error means that the server is looking for an agent configured with hostname Exchange01, but doesn't have a host configured with this hostname.

Check the agent and the server and make sure the hostname is configured to be exactly the same at both the agent and server. This also means you can't have a short name at one end and FQDN at the other. They must completely match.

By default the Zabbix agent gets the hostname from the item system.hostname. You can edit zabbix_agentd.win.conf and set Hostname= to override the hostname.

| improve this answer | |
  • Thanks, but the host names are all identical. – dynmatt Aug 8 '18 at 15:02
  • Then it's probably your proxy, as the other answer suggests. – Michael Hampton Aug 8 '18 at 15:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.