2

In Hyper-V 2016, I'm getting an error "Operation not supported" when attempting to move my VM configurations from a USB drive to the default folders. I have only one host machine; I exported them to the drive so I could perform some hardware upgrades that necessitated an OS reinstall. (The new disk array is still building, so I'll forego moving the VHDXs for now. The configurations are working, but I'd like to get them off the USB drive.)

The options I'm choosing are detailed in the screenshots below.

Things I've tried:

  1. Shutting down the VM (An Ubuntu Server instance)
  2. Moving just the main configuration, leaving out Checkpoints and Smart Paging
  3. Running the migration in PowerShell

PowerShell:

$Path = "C:\ProgramData\Microsoft\Windows\Hyper-V"
Move-VM -Name "MATRIX" -DestinationHost "SERVER1" -VirtualMachinePath $Path -SnapshotFilePath $Path -SmartPagingFilePath $Path

This fails with the same error:

The operation is not supported.

How can I successfully move these configurations to their default locations on the Hyper-V host?


enter image description here enter image description here enter image description here enter image description here enter image description here enter image description here enter image description here enter image description here enter image description here enter image description here

  • Can you check the Hyper-V event logs on the servers and see if you can find some interestring informations ? Open the EventViewer, and take a look at all the logs that starts with "Hyper-V", you will find more info about the Hyper-V Logs here: blogs.technet.microsoft.com/virtualization/2018/01/23/… – Swisstone Aug 9 '18 at 18:35
  • @Swisstone ~ Well now that's interesting! Blocked a migration operation for virtual machine 'MATRIX' because the host is not configured for the migration operation (virtual machine ID 544B1F0A-5BF5-4B93-B0BB-6DD0AA2704FD). Both Live and Storage Migrations are enabled; I'm allowing 4 simultaneous of each. For Live Migrations I'm using any available network, CredSSP and Compression. I'm not sure what else there is to do, but at least (with your assistance) I've been able to track down a strong clue. – InteXX Aug 9 '18 at 21:43
  • @Swisstone ~ OK, I found the answer. See below. – InteXX Aug 11 '18 at 21:33
0

The error was occurring because I was trying to migrate a VM from one location to another on the same host. This action isn't supported—the concept of VM migration implies two separate hosts. (But not storage migration; this can be done within the same host without any problem. I suppose that's what left me thinking that I could do the same for configurations.)

I ended up doing this for each VM:

  1. Create a new configuration with a slightly different name
  2. Manually copy the settings from the old configuration to the new
  3. Delete the old configuration
  4. Rename the new configuration

This worked just fine.

Frustration: If the error message had stated the true problem, it would have saved us all a lot of trouble. In literally a second I would have decided to approach the task in the way I've described, had I known what was really happening. I learned during my investigations that Hyper-V is infamous for this error reporting shortcoming. Somebody somewhere took some ill-advised shortcuts.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.