0

The Nginx tutorial shows PHP 5 being used in FastCGI mode on Windows, but PHP 4 doesn't support php-cgi.exe so it must be run in traditional cgi mode,

There are two ways to set up PHP to work with Apache 1.3.x on Windows. One is to use the CGI binary (php.exe for PHP 4 and php-cgi.exe for PHP 5), the other is to use the Apache Module DLL. In either case you need to edit your httpd.conf to configure Apache to work with PHP, and then restart the server.

Does anyone have a configuration to use PHP 4 in in CGI (not-fastCGI mode on NGINX) I didn't see this in the docs.

  • 1
    PHP 4 has been end of life for over a decade , was nginx already around then, let alone supporting Windows and php? – HBruijn Aug 10 '18 at 7:53
  • Nginx doesn't support CGI (and never was). – Alexey Ten Aug 10 '18 at 10:46
  • BTW, nginx on windows still in beta. – Alexey Ten Aug 10 '18 at 10:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.