2

I'm moving an old .Net 2 web service from a Windows 2008 R2 server to a new Windows 2016 Datacenter server. It has something else set up on the Default Web Site, but I have created an additional one for the web service. (This is exactly the same scenario as the old server.) I have the physical path set to the same place as before. The web service installer (which was made by PowerBuilder 11.5) actually creates another folder under the physical path where it puts the files.

The problem is that I need the URL to be https://subdomain.domain.com/webservice.asmx, as it was on the old server. Instead, it is insisting on only working at https://subdomain.domain.com/webservicefolder/webservice.asmx. I have tried moving the physical path value down one folder, and it still behaves the same way. I have tried playing with the HTTP Redirect and URL Rewrite features, but the most I've been able to accomplish is a message saying that it has been moved, rather than automatically redirecting.

I tried doing what's described here, and get an error 503 when using the desired URL, and the URL with the folder included is still working: https://blog.discountasp.net/root-redirection-to-subdirectory/

What is the proper way to do this?

  • It is super easy if you compare applicationHost.config of the two servers. – Lex Li Aug 13 '18 at 23:08
  • Thanks, but the <site> settings are actually the same on both. Is there another section I should be looking at? – atariguy Aug 14 '18 at 16:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.