0

So I was trying to install nginx on my virtual machine. I firstly used epel repository, but it couldn't resolve some dependencies. So I configured nginx repository and tried installing nginx again. However one dependency still remains:

Error: Package: 1:nginx-1.14.0-1.el7_4.ngx.x86_64 (nginx) Requires: libcrypto.so.10(OPENSSL_1.0.2)(64bit)

So I searched how can I update openssl version, and I found a procedure here. I followed the steps, and when I ran openssl version, the output was:

OpenSSL 1.0.2o 27 Mar 2018

So I thought the dependency has been resolved. I tried installing nginx again, but same problem showed up again. When I ran yum info openssl, I received this output:

Name : openssl Arch : x86_64 Epoch : 1 Version
: 1.0.1e Release : 42.el7 Size : 1.5 M Repo : installed From repo : anaconda Summary : Utilities from the general purpose cryptography library with TLS : implementation URL : http://www.openssl.org/ License : OpenSSL Description : The OpenSSL toolkit provides support for secure communications : between machines. OpenSSL includes a certificate management tool : and shared libraries which provide various cryptographic : algorithms and protocols.

Now I am highly confused. Why openssl version is showing OpenSSL 1.0.2o while yum info openssl is showing the version to be 1.0.1e. Am I missing something out here?

How can this be resolved? And even after useing nginx repository, I am unable to install nginx due to dependencies. What can be done to resolve this issue?

Any help is appreciated. Many thanks.

3
  • yum only knows about packages, and gives you info about the package that is installed, or could be installed from the configured repositories. You bypassed the package system by installing from source, and since 1.0.1 and 1.0.2 have ABI differences, any other programs on your system that use OpenSSL may fail or corrupt data without warning. But rpmfind says RH7 already bases on 1.0.2k; are you really sure you have RH7 (or CentOS 7)? Aug 15 '18 at 10:15
  • Yes, I'm working on Rhel 7.1 and I'm still unable to figure out why this dependecy is not getting resolved. Aug 15 '18 at 10:22
  • 1
    Update the system first. You should not be on RHEL 7.1. This nginx package requires 7.4 at minimum, and you should be on 7.5 anyway. Aug 15 '18 at 13:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.