2

We're trying to migrate a couple of classic VMs in classic vnet over to ARM ('non-classic'). I've been following the Microsoft powershell migration steps here but the migration (and validation) fails with the message:

"An unknown error occurred while validating Azure Resource Manager Compute quota of Deployment PMIEFCRM for IaaS Classic to Azure Resource Manager migration.".

I'm not 100% sure, but I think this might be related to the Azure Powershell tool not being able to retrieve our quota limits. Partly because "quota" is mentioned in the error, but also partly because if I try and check the quotas by using Get-AzureRmVMUsage -Location "East US" (or another region) then it just shows all zeros for our current usage. Could this be due to our subscription or ARM quotas not being set up correctly?

I've also tried using the Azure cli steps here instead of Powershell but see the same error.

Plus I've tried recreating the classic VMs outside of the vnet and then migrating them individually, in case the vnet was the problem, but saw the same error again.

Any help or suggestions much appreciated!

  • Can you try just manually creating an ARM VM manually? The error seems to indicate you have hit your core quota, this should give you a better error if that is the case. – Sam Cogan Aug 25 '18 at 9:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.