0

I am trying to connect my Macbook to an Azure VPN. Each time I try to connect the connection animation of the VPN icon on the top bar (enter image description here) goes on for a few seconds and then stops, without any explanations about what went wrong.

I followed all the instructions to the letter, double, triple and quadruple-checked everything. Deleted all certificates and started over, but still no success.

When sniffing with WireShark, all I get is a short conversation which I can't find any hints in for what could be wrong:

WireShark

tailing /var/log/system.log I can see this:

DATE Macbook nesessionmanager[16073]: NESMIKEv2VPNSession[PreProd:39C837FA-09F7-42BD-AD8D-F85994AB9470]: Received a start command from SystemUIServer[282]
DATE Macbook nesessionmanager[16073]: NESMIKEv2VPNSession[PreProd:39C837FA-09F7-42BD-AD8D-F85994AB9470]: status changed to connecting
DATE Macbook nesessionmanager[16073]: Failed to find the VPN app for plugin type com.apple.neplugin.IKEv2
DATE Macbook neagent[24535]: IKEv2 Plugin: ikev2_dns_callback: Error -65554
DATE Macbook kernel[0]: ipsec_ctl_connect: creating interface ipsec0
DATE Macbook configd[55]: network changed
DATE Macbook kernel[0]: hfs: mounted Recovery HD on device disk0s3
DATE Macbook mds[66]: (Volume.Normal:2464) volume:0x7fcf1c016000 ********** Bootstrapped Creating a default store:0 SpotLoc:(null) SpotVerLoc:(null) occlude:0 /Volumes/Recovery HD
DATE Macbook sandboxd[132] ([283]): Finder(283) System Policy: deny file-write-create /Volumes/Recovery HD/.Trashes/501
DATE Macbook fseventsd[48]: Logging disabled completely for device:1: /Volumes/Recovery HD
DATE Macbook kernel[0]: hfs: unmount initiated on Recovery HD on device disk0s3
DATE Macbook kernel[0]: hfs: mounted Recovery HD on device disk0s3
DATE Macbook mds[66]: (Volume.Normal:2464) volume:0x7fcf1a856c00 ********** Bootstrapped Creating a default store:0 SpotLoc:(null) SpotVerLoc:(null) occlude:0 /Volumes/Recovery HD
DATE Macbook kernel[0]: hfs: unmount initiated on Recovery HD on device disk0s3
DATE Macbook sandboxd[132] ([283]): Finder(283) System Policy: deny file-write-create /Volumes/Recovery HD/.Trashes/501
DATE Macbook neagent[24535]: Authentication method did not match
DATE Macbook neagent[24535]: Failed to process IKE Auth packet
DATE Macbook symptomsd[238]: -[FlowAnalyticsEngine _newFlowData:] netanalyticsdebug: (2) no head-end for flow azuregateway-515cbc58-3610-48a3-958f-6362b55579cb-e4f08f898b02.vpn.azure.com, discarding all its records
DATE Macbook neagent[24535]: Failed to receive packet
DATE Macbook neagent[24535]: BUG in libdispatch client: kevent[EVFILT_READ] delete: "Bad file descriptor" - 0x9
DATE Macbook nesessionmanager[16073]: NESMIKEv2VPNSession[PreProd:39C837FA-09F7-42BD-AD8D-F85994AB9470]: status changed to disconnecting
DATE Macbook kernel[0]: SIOCPROTODETACH_IN6: ipsec0 error=6
DATE Macbook nesessionmanager[16073]: NESMIKEv2VPNSession[PreProd:39C837FA-09F7-42BD-AD8D-F85994AB9470]: status changed to disconnected, last stop reason Stop command received
DATE Macbook configd[55]: network changed
DATE Macbook symptomsd[238]: nw_interface_create_with_name netutil_ifname_to_ifindex(ipsec0) failed, dumping backtrace:
            [x86_64] libnetcore-583.50.1
        0   libsystem_network.dylib             0x00007fff9c67cde9 __nw_create_backtrace_string + 123
        1   libsystem_network.dylib             0x00007fff9c69f1f3 nw_interface_create_with_name + 179
        2   Network                             0x00007fff8992cedc -[NWInterface initWithInterfaceName:] + 120
        3   SymptomEvaluator                    0x00007fff9a9482fc config_callback + 874
        4   SystemConfiguration                 0x00007fff9b823faf rlsPerform + 184
        5   SystemConfiguration                 0x00007fff9b8373ab __SCDynamicStoreSetDispatchQueue_block_invoke_2 + 52
        6   libdispatch.dylib                   0x00007fff9b01893d _dispatch_call_block_and_release + 12
        7   libdispatch.dylib                   0x00007fff9b00d40b _dispatch_client_callout + 8
        8   libdispatch.dylib                   0x00007fff9b01203b _dispatch_queue_drain + 754
        9   libdispatch.dylib                   0x00007fff9b018707 _dispatch_queue_invoke + 549
        10  libdispatch.dylib                   0x00007fff9b010d53 _dispatch_root_queue_drain + 538
        11  libdispatch.dylib                   0x00007fff9b010b00 _dispatch_worker_thread3 + 91
        12  libsystem_pthread.dylib             0x00007fff893544de _pthread_wqthread + 1129
        13  libsystem_pthread.dylib             0x00007fff89352341 start_wqthread + 13
DATE Macbook symptomsd[238]: -[NWInterface initWithInterfaceName:] nw_interface_create_with_name(ipsec0) failed, dumping backtrace:
            [x86_64] libnetcore-583.50.1
        0   libsystem_network.dylib             0x00007fff9c67cde9 __nw_create_backtrace_string + 123
        1   Network                             0x00007fff8992cf46 -[NWInterface initWithInterfaceName:] + 226
        2   SymptomEvaluator                    0x00007fff9a9482fc config_callback + 874
        3   SystemConfiguration                 0x00007fff9b823faf rlsPerform + 184
        4   SystemConfiguration                 0x00007fff9b8373ab __SCDynamicStoreSetDispatchQueue_block_invoke_2 + 52
        5   libdispatch.dylib                   0x00007fff9b01893d _dispatch_call_block_and_release + 12
        6   libdispatch.dylib                   0x00007fff9b00d40b _dispatch_client_callout + 8
        7   libdispatch.dylib                   0x00007fff9b01203b _dispatch_queue_drain + 754
        8   libdispatch.dylib                   0x00007fff9b018707 _dispatch_queue_invoke + 549
        9   libdispatch.dylib                   0x00007fff9b010d53 _dispatch_root_queue_drain + 538
        10  libdispatch.dylib                   0x00007fff9b010b00 _dispatch_worker_thread3 + 91
        11  libsystem_pthread.dylib             0x00007fff893544de _pthread_wqthread + 1129
        12  libsystem_pthread.dylib             0x00007fff89352341 start_wqthread + 13
DATE Macbook symptomsd[238]: nw_interface_create_with_name netutil_ifname_to_ifindex(ipsec0) failed, dumping backtrace:
            [x86_64] libnetcore-583.50.1
        0   libsystem_network.dylib             0x00007fff9c67cde9 __nw_create_backtrace_string + 123
        1   libsystem_network.dylib             0x00007fff9c69f1f3 nw_interface_create_with_name + 179
        2   Network                             0x00007fff8992cedc -[NWInterface initWithInterfaceName:] + 120
        3   SymptomEvaluator                    0x00007fff9a9482fc config_callback + 874
        4   SystemConfiguration                 0x00007fff9b823faf rlsPerform + 184
        5   SystemConfiguration                 0x00007fff9b8373ab __SCDynamicStoreSetDispatchQueue_block_invoke_2 + 52
        6   libdispatch.dylib                   0x00007fff9b01893d _dispatch_call_block_and_release + 12
        7   libdispatch.dylib                   0x00007fff9b00d40b _dispatch_client_callout + 8
        8   libdispatch.dylib                   0x00007fff9b01203b _dispatch_queue_drain + 754
        9   libdispatch.dylib                   0x00007fff9b018707 _dispatch_queue_invoke + 549
        10  libdispatch.dylib                   0x00007fff9b010d53 _dispatch_root_queue_drain + 538
        11  libdispatch.dylib                   0x00007fff9b010b00 _dispatch_worker_thread3 + 91
        12  libsystem_pthread.dylib             0x00007fff893544de _pthread_wqthread + 1129
        13  libsystem_pthread.dylib             0x00007fff89352341 start_wqthread + 13
DATE Macbook symptomsd[238]: -[NWInterface initWithInterfaceName:] nw_interface_create_with_name(ipsec0) failed, dumping backtrace:
            [x86_64] libnetcore-583.50.1
        0   libsystem_network.dylib             0x00007fff9c67cde9 __nw_create_backtrace_string + 123
        1   Network                             0x00007fff8992cf46 -[NWInterface initWithInterfaceName:] + 226
        2   SymptomEvaluator                    0x00007fff9a9482fc config_callback + 874
        3   SystemConfiguration                 0x00007fff9b823faf rlsPerform + 184
        4   SystemConfiguration                 0x00007fff9b8373ab __SCDynamicStoreSetDispatchQueue_block_invoke_2 + 52
        5   libdispatch.dylib                   0x00007fff9b01893d _dispatch_call_block_and_release + 12
        6   libdispatch.dylib                   0x00007fff9b00d40b _dispatch_client_callout + 8
        7   libdispatch.dylib                   0x00007fff9b01203b _dispatch_queue_drain + 754
        8   libdispatch.dylib                   0x00007fff9b018707 _dispatch_queue_invoke + 549
        9   libdispatch.dylib                   0x00007fff9b010d53 _dispatch_root_queue_drain + 538
        10  libdispatch.dylib                   0x00007fff9b010b00 _dispatch_worker_thread3 + 91
        11  libsystem_pthread.dylib             0x00007fff893544de _pthread_wqthread + 1129
        12  libsystem_pthread.dylib             0x00007fff89352341 start_wqthread + 13
DATE Macbook kernel[0]: hfs: mounted Recovery HD on device disk0s3
DATE Macbook mds[66]: (Volume.Normal:2464) volume:0x7fcf22841600 ********** Bootstrapped Creating a default store:0 SpotLoc:(null) SpotVerLoc:(null) occlude:0 /Volumes/Recovery HD
DATE Macbook fseventsd[48]: Logging disabled completely for device:1: /Volumes/Recovery HD
DATE Macbook kernel[0]: hfs: unmount initiated on Recovery HD on device disk0s3
DATE Macbook sandboxd[132] ([283]): Finder(283) System Policy: deny file-write-create /Volumes/Recovery HD/.Trashes/501
DATE Macbook kernel[0]: hfs: mounted Recovery HD on device disk0s3
DATE Macbook mds[66]: (Volume.Normal:2464) volume:0x7fcf1c016000 ********** Bootstrapped Creating a default store:0 SpotLoc:(null) SpotVerLoc:(null) occlude:0 /Volumes/Recovery HD
DATE Macbook kernel[0]: hfs: unmount initiated on Recovery HD on device disk0s3
DATE Macbook sandboxd[132] ([283]): Finder(283) System Policy: deny file-write-create /Volumes/Recovery HD/.Trashes/501

I can't figure from this what the problem is. I tried Googling the error messages that look suspicious, but the results were disappointing...

Can anyone somehow point me in the right direction for how to continue investigating this...?

1

It seems that it's a bug.

A similar case which has the same scenario in the logs as you.

Also, you can try this method: In ipsec.conf, update the ciphers and the rightauth.

rightauth=eap-tls
ike=3des-sha1-modp1024
esp=3des-sha1-modp1024

Ref: https://apple.stackexchange.com/questions/217366/ikev2-vpn-el-capitan-10-11

Finally, you can post a message to one of Apple's mailing lists: https://lists.apple.com/mailman/listinfo

  • ipsec.conf is for strongswan. However in my case the VPN server is MS Azure, and I have no control over protocols or ciphers. – Amir Abiri Aug 30 '18 at 14:17
  • 1
    Ah~It's MAC bug even that you have not use VPN server in MS Azure. – Nancy Xiong Aug 30 '18 at 14:51
  • You are right. I'm just saying that the suggested workaround isn't applicable for this (same issue) but on Azure. – Amir Abiri Sep 3 '18 at 9:29
0

Go to your VPN connection on OSX, under Authentication Settings select None, and then choose Certificate (your certificate should show up). Hit Connect, now it doesn't disconnect anymore!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.