0

Following a couple of tutorials to achieve the main goal -setting up PHP-FPM on Ubuntu 16 - I also had to install the FastCgi-Module for Apache 2.4.18 with apt-get install libapache2-mod-fastcgi.

This of course will only work after adding "multiverse" to /etc/apt/sources.list.

After successful installation I'll find a file called fastcgi.conf in /etc/apache2/mods-enabled.

So far. So good. But: After passing PHP-calls from Apache to the PHP-FPM-process with this line in the vhost-config:

<IfModule mod_fastcgi.c>
    ProxyPassMatch ^/(.*\.php(/.*)?)$ unix:/run/php/php-fpm-www.sock|fcgi://123.123.123.123/
</IfModule>

the Apache-Log shows the following error when calling a PHP-file:

FastCGI: failed to connect to server "/usr/lib/cgi-bin/php5-fcgi":

This file apparently does not exists. Checking the fastcgi-configuration in /etc/apache2/mods-enabled/fastcgi.conf I find a lot of PHP5-stuff, like:

 AddType application/x-httpd-fastphp5 .php
 Action application/x-httpd-fastphp5 /php5-fcgi
 Alias /php5-fcgi /usr/lib/cgi-bin/php5-fcgi
 FastCgiExternalServer /usr/lib/cgi-bin/php5-fcgi -    socket /var/run/php5-fpm.sock -pass-header Authorization

So my question is: How can I actuall install the current fastcgi-Module or why does the installation script does not configure the module as expected?

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.