2

I have S2D setup using 2 Azure VMs in a mirror. When I originally set it up, I did so following the instructions here: https://docs.microsoft.com/en-us/windows-server/remote/remote-desktop-services/rds-storage-spaces-direct-deployment

This worked great with no problems. When I set it up, I chose to use 128GB datadisks. With 2 disks on each vm, I had 252GB of capacity in my volume.

Now I'm coming back to this set up and I wanted to add more capacity. I added a 1023GB datadisk to each vm. Waited for the storage pool to automatically add them, which it did. Then I tried to Resize my virtual disk using the information here: https://docs.microsoft.com/en-us/windows-server/storage/storage-spaces/resize-volumes

When looking at my Storage pool in the "Failover Cluster Manager" it indicated that I had 2.00 TB of free space. I assumed I could only use half of that, so my new capacity should be approximately 1.2 TB when combined with my original capacity.

When I ran the "Resize-VirtualDisk" powershell command it told me there wasn't enough available capacity. So then I started just reducing the size and finally got it to work if I resized to 500GB.

So adding 2 x 1TB disks only gave me an extra 250GB of capacity. Why is this? I've been trying to figure out and understand how this all works, but I can't find a definitive answer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.