0

There are 2 users on machine#0: user#0 and user#1. I can mount the desired dir from user#0 on machine#0 executing:

sshfs user@hostname:/home/folder /home/folder

The thing is that /home/folder has some-path/user#1 inside, which is home directory for user#1. But when I try to

ssh user1@machine0

After entering password it says Connection to machine0 closed. If I switch home of user1 to another, local directory, I have no problems logging in. Why is this happening and how to make this work? Thank you!

  • Have you checked your logs? – yoonix Aug 30 '18 at 21:25
  • I am sorry, what exactly do you mean by "checking logs" in this situation? :) – Anton Ostrouhhov Aug 30 '18 at 21:37
0

Ok, I have found the solution.

  1. In my case (embedded-linux), it was necessary to add user1 to aid_inet and aid_net_raw groups in /etc/group file.

  2. allow_other option had to be enabled when mounting fs, just like that:

    sshfs user@hostname:/home/folder /home/folder -o allow_other

Thanks!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.