-1

I had a local webserver that was working fine and on which I had a website on domain example.com. I was also using a static public IP for the WAN with ISP #1. Now I decided to move the website to a remote hosting company so I changed the A records of my domain to point to that new server. The replication of the A record has been done about 2 weeks ago now.

My main local router is a pfSense v2.4.3 and I removed all the configurations I did for the old local server, but still, when I am inside this pfsense network, I can't access the site at the new location. I get DNS_PROBE_FINISHED_NXDOMAIN error. If I try outside of the network, it works fine. Recently I changed to ISP company #2 and went to a dynamic public IP. The ISP company came here, installed a new modem/router and put it in front of the pfSense router. If I try the website when connected to this very first router, everything work fine. So I know it's not a problem of the ISP DNS. So there is something in the pfSense that keeps something somewhere but can't find what it is.

What I tried :

I have disabled DNS Forwarder and DNS Resolver to force queries to bypass the pfSense DNS;

When enabling DNS Resolver, it shows "unbound" in the Status>Services page. Restarting the service doesn't change;

I tried putting Google DNS in the DNS Servers;

I did a reset of the connections states of the pfSense;

None of this worked.

On the pfSense, the DNS Lookup returns: Host "example.com" could not be resolved. Also it seems (unconfirmed) that my domain cannot resolve for everyone. Someone outside of the local network told me that he could not access my domain, but at this time, I was also outside the pfSense network and could access it successfully.

  • Downvoters, care to share why this is not a good question? – M.Parent Sep 1 '18 at 12:40
0

It turned out to be a simple issue. Despite doing ipconfig /flushdns, I saw that the DNS servers were still coming from the pfSense router. Even if I kept disabled the DNS Resolver on the router, it continued to serve requests. I had to do an ipconfig /renew to finally get the DNS servers from google.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.