0

I want to FTP into IBM i (AS400) directly to "legacy file system".

Some sites talks about adding these lines to appropriate section.

<PostLoginCommands>         
  <Command>site namefmt 1</Command>
  <Command>site listfmt 1</Command>
  <Command>cwd /QSYS.LIB/USERLIB.LIB </Command>
  <Command>TYPE A</Command>
</PostLoginCommands>

I found setup file in C:\Users\USERNAME\AppData\Roaming\FileZilla I know that this is correct file because when I deleted contents Filezilla lost setup menu.

Unfortunately this does not work for me. Filezilla seems to ignore the section entirely.

1

Check CHGFTPA command on IBMi. In Filezilla, put /QSYS.LIB/TEMP.LIB or something like that in the remote directory.

That works for me.

| improve this answer | |
0

Think you're missing the QOUTE

This works for me...

        <PostLoginCommands>
            <Command>qoute site namefmt 1</Command>
            <Command>qoute site listfmt 1</Command>
            <Command>cwd /QSYS.LIB/MYLIB.LIB</Command>
        </PostLoginCommands>

Note that this goes into the sitemanager.xml file, not sure if that's the "setup file" you're talking about.

So you'd need to add an entry for your IBM i via the site manager utility within FileZilla, close FileZilla, and edit the entry in sitemanager.xml adding the commands above after the <port>21</port> line. Save and restart FileZilla and use the site manager utility to connect to your system.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.