0

I connect to a KVM host (CentOS 7) by VNC. The keymap on the host is de-ch. While connected to the host i open a guest server (any OS) by the virt-manager and try to login to the guest, but the keymap is set to en-us. The guest server self has also the keymap de-ch. Also when i set the keymap in the spice server of the guest manually to de-ch, the keymap of the guest server is still en-us. This happens just when i connect to the host by VNC. When i use the host server with my display and a keyboard and open in the virt-manager a guest, the keymap is correct. How can i fix this?

  • Stop using VNC this instant! It is not secure, and anybody in the network path can see everything you are doing, including your passwords. Consider them compromised (as they are) and change them all. Run virt-manager locally and it can connect to your remote server with its built-in ssh tunnelling. – Michael Hampton Sep 5 '18 at 21:29
  • It's in the local intranet, so i see there at the moment no security risk. – dingsda Sep 5 '18 at 21:31
0

I found finaly the solution. Its the Spice option. When i change it to VNC, the keymap is correct.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.