0

I have three Windows 2008 R2 servers with MDT and WDS installed. It was reported multicasting stopped working on all of them. I made sure the multicast option was selected in the deployment shares' properties, but when I went to Windows Deployment Services in server manager, there were no servers showing there. When I tried to add local computer I got the "A directory service error has occurred" error.

The WDS service was running, though, and I was able to restart it, but it didn't help. I rebooted the server, then uninstalled WDS, rebooted again and reinstalled it, rebooted once more. WDS appeared again, but there was still no server under the servers node and I still couldn't add any getting the same error. Also, after reinstalling WDS, the WDS service won't start at all now.

I tried running the below commands, but they failed throwing the "directory service error", I just because there was no server added:

wdsutil /uninitialize-server wdsutil /initialize-server /reminst:[PATH_TO_REMOTEINSTALL_DIRECTORY]

I enabled tracing and when trying to start the WDS service I get a bunch of errors in WDSServer.log, but I believe they might be irrelevant, and all boil down to no server showing under the "Servers" node. I found a similar thread here https://social.technet.microsoft.com/Forums/windows/en-US/265b4b53-63ac-491f-817c-6030daa39b81/cant-start-quotwindows-deployment-servicesquot-service?forum=itprovistadeployment, but the suggested solutions don't work for me, as explained above.

It puzzles me that all three servers lost the WDS functionality, can it be something related to AD? I made sure domain, DNS servers etc. are pingable and the computer accounts have necessary privileges set in AD.

I searched the internet high and low, but couldn't find any information on exactly such an issue, so any help will be greatly appreciated.

  • Update: there's another MDT server with WDS installed - it resides in the same OU and on the same subnet, but the OS is W2012R2. WDS looks fine there and I can also add other MDT servers under the WDS>Servers node (the ones I can't add on themselevs). The issue seems to be limited to W2008R2. – Tomasz Szymon Sep 11 '18 at 13:05
0

In the Windows Deployment Services application, try right clicking on "Servers," selecting "Add Server", leave "Local Computer" checked if it's on the same server you're on, then select "Okay." Let me know if this doesn't work. There will still need to be a few more troubleshooting steps, but hopefully this will actually let you configure the WDS.

  • Thank you Kirk for taking a look at this. Unfortunately this is exactly the problem - I can't add local computer under WDS>Servers, because I am getting the "A directory service error has occurred" error then. I explained this in the first paragraph of my post. – Tomasz Szymon Sep 7 '18 at 18:00
0

I still don't know the root cause of this issue, but it must have been something related to policies/GPO's, as the error implied.

I replicated and fixed the fault in test evironment first: - set up a Windows Server 2008R2 VM (W2012 or 2012R2 were not affected) - other issues that always co-occured with he main one included: RSOP.msc would not open, gpupdate would fail with the error saying there was no RSOP data for the user, I was prompted for credentials when accessing network shares on other servers from the affected server, I couldn't add any AD groups or users to local groups (e.g. Remote Desktop Users), because they could not be found after I clicked "check name". - Found an equivalent W2008R2 server where the above issues did not occur - Moved the test server to the same OU as the equivalent one - All above issues stoppped occuring - Installed WDS on the test server - it appeared under WDS.msc>Servers fine and I could configure it - The issues didn't return after I moved the test server to the OU it was supposed to reside in.

However, moving the original affected server to the equivalent OU was not enough and I had to: - Uninstall all server roles (WDS, File Services and IIS) - Move the server to the equivalent OU - Reinstall all roles - Manually recreate the deployment shares under file services - Configure WDS with multicast: https://keithga.wordpress.com/2014/04/23/multicasting-with-mdt/

This fixed all issues and made multicast work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.