1

When I try to setup Active Directory on Windows Server 2012 or 2016 on Google Cloud (using the default VM images with Desktop Experience), it fails on creating a forest with the error:

...The local Administrator account becomes the domain Administrator account when you create a new domain. The new domain cannot be created because the local Administrator account password does not meet requirements.

Currently, the local Administrator password is blank, which might lead to security issues...

This is unexpected, because

  1. The administrator password is a very secure password generated by Google.
  2. I am trying this on fresh servers using a completely default setup.
  3. I am following the directions at tenforums
  4. I even found a video of these directions working from two years ago on Youtube

Attempted solutions which did not work:

  • Rebooting
  • Changing the administrator password using CTRL-ALT-DELETE and using control panel
  • Connecting using remote desktop from both Ubuntu and Windows 8
  • Changing the domain name to something which is not a public URL

I have no idea what is going on, so even hints on where to start would be helpful.

UPDATE

It appears there are two separate accounts (my default account and an account named 'Administrator') even though only one account shows up in Control Panel User Settings. I followed Google's directions to setup AD, but they fail when I run

net use Administrator *

with the error

System error 67 has occurred.

The network name cannot be found.
2

Using Control Panel, choose: User Accounts|User Accounts|Manage another account, you will find an "Administrator" account, a "Guest" account besides your current administrator account. Your current administrator account is Password protected. Create a password for the "Administrator" account, then the problem is solved.

0

Google's directions work perfectly. The directions from TenForum and YouTube also work as long as you run this command:

net user Administrator *

from a PowerShell window. PowerShell must be run as Administrator (right click on the icon to find the option). Note that the command is user not use.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.