I would like Putty (or the OS - WinXP) to remember the size/position of the window. The rows/columns settings only affects the work area, but does not "zoom in". I would like the same effect as I get when I drag the window border and the content of the putty window resizes accordingly.

5 Answers 5


When you resize the window in putty, it by default changes the number of rows and columns in the terminal. This is the same thing as setting the rows and columns for the session configuration.

When I change the rows and columns for a session before I start it, I get the same effect as if I'd dragged the window to this size.

Perhaps this isn't your question. Are you remember to save the session? The Putty interface is sorta silly. Load up your saved session, change the columns and rows by clicking "Window" in the tree, then click "Session" in the tree and then "Save". Now whenever you load the session your newly chosen window size will load.


My solution is more generic and utilizes AutoSizer which allows you to auto position and size any window. However I run into a small(big) problem in that Putty's (I use Kitty personally) windows don't include the running command so AutoSizer can not distinguish between them.

This however can be solved by editing the bash startup script so that it updates the session title on command execution - see my answer here.

Having this setup allows me to have my long running tail and htop putty session automatically positioned by AutoSizer on a third monitor when started.

AutoSizer position KiTTY Windows


There appears to be a bug Changing KiTTY Window Title with KiTTY that resets the title on window resize; please add a comment to the thread and say you are having the issue too.

Also when using AutoSizer note it does not 'grab' the right window size when they are snapped so as a work around position them manually to get the right sizes.


It sounds like you have the option "When the window is resized: Change the size of the font" selected. If you want to achieve the "zoom in" effect you're describing, try changing the font size under the Window -> Appearance settings.


it seems this putty clone does what you want and more things... at least auto-save the default sesion (awesome) remember the last 4 hosts conected (awesome) 3 complete color themes (I thought this was silly but I've got used and now I enjoy this a lot)


see ya


If there is no option anywhere in putty, that is no setting that is supported by putty I think.

I know this doesn't exactly solve your problem, but for all the default settings in putty, you can just run it and before loading anything change the defaults:

When you've done that, just go back to the "home screen" of the application and save without entering any name. Therefor these settings are remembered as the default.

As a sidenote: You could also turn on X11 forwarding, then open the connection with a default command that opens an xterm on the other side, which is displayed locally, and you could configure that one to your needs... just install Xming as an X server on your machine and all windows will be shown locally on your machine, but run on the other one.

Small hint: if the performance you're getting is too bad, try out x2go.org :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy