I am running Nextcloud 14 on Debian Stretch with nginx, php-fpm7.2, mariadb and redis inside a LXC container (Proxmox VE, lvm thin storage). On another LXC container, alpine linux 3.8 runs an nginx reverse proxy.

For some reason i can not upload files larger than one megabyte.

I already tried/checked the following:

  • php upload_max_filesize = 16G
  • php post_max_size = 16G
  • php output_buffering = Off
  • php max_input_time = 3600
  • php max_execution_time = 3600
  • php memory_limit = 1024M
  • php upload_tmp_dir = /upload_tmp/ (permissions and available space are fine)
  • nginx client_max_body_size 16G;
  • nginx fastcgi_read_timeout 3600;
  • nginx client_body_temp_path /upload_tmp;
  • reverseproxy proxy_buffering off;
  • reverseproxy proxy_request_buffering off;

Does someone have an idea, where else i could take a look?

1 Answer 1


The problem was the reverse proxy. In the http block was another client_max_body_size set to 1m. Setting it to 0 solved it. Found the solution here: https://serverfault.com/a/401732/393856


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .