I can not compile samba,I make the command "./configure" and it returns this error "Samba AD DC and --enable-selftest requires lmdb 0.9.16 or later"

  • 2
    That error message sounds pretty clear. Have you tried installing lmdb 0.9.16 or later? – ceejayoz Sep 12 at 19:05
  • Why don't you have used the ports or even the packages? – Kondybas Sep 12 at 19:32
  • insert the command "cd /usr/ports/databases/lmdb/ && make install clean" to install the port and also "pkg install lmdb" but it did not work – Mr.John Sep 12 at 19:37
  • or how would you install it? – Mr.John Sep 12 at 19:38
up vote 2 down vote accepted

First of all you have to install the port tree:

portsnap fetch extract

That will take some time. Then you have to move to the root of ports:

cd /usr/ports

Now you are able to search for the software you need. Do not look for the auxiliary software that called dependencies - look directly for those software you really need:

make search name=samba48

You'll get a lot of lines:

Port:   samba48-4.8.5_1
Path:   /usr/ports/net/samba48
Info:   Free SMB/CIFS and AD/DC server and client for Unix
Maint:  timur@FreeBSD.org
B-deps: ca_root_nss-3.39 cmocka-1.1.1_1 expat-2.2.6_1 gamin-0.1.10_9
gettext-runtime-0.19.8.1_1 glib-2.50.3_5,1 gmp-6.1.2 gnutls-3.5.19 
indexinfo-0.3.1 jansson-2.11 libarchive-3.3.2,1 libffi-3.2.1_2  
libiconv-1.14_11 libidn2-2.0.5 libinotify-20180201 liblz4-1.8.2,1 
libsunacl-1.0.1 libtasn1-4.13 libunistring-0.9.10 lzo2-2.10_1
ncurses-6.1.20180728 nettle-3.4 openldap-client-2.4.46 p11-kit-0.23.14 
p5-Parse-Yapp-1.05_2 pcre-8.42 perl5-5.26.2 pkgconf-1.4.2,1 
popt-1.16_2 py27-setuptools-40.0.0 py36-dnspython-1.15.0 py36-iso8601-0.1.11 
python27-2.7.15 python36-3.6.6_1 readline-7.0.3_1 talloc-2.1.14 
tdb-1.3.16,1 tevent-0.9.37 tpm-emulator-0.7.4_2 trousers-0.3.14_2
R-deps: ca_root_nss-3.39 cmocka-1.1.1_1 expat-2.2.6_1 gamin-0.1.10_9
gettext-runtime-0.19.8.1_1 glib-2.50.3_5,1 gmp-6.1.2 gnutls-3.5.19
indexinfo-0.3.1 jansson-2.11 libarchive-3.3.2,1 libffi-3.2.1_2 
libiconv-1.14_11 libidn2-2.0.5 libinotify-20180201 liblz4-1.8.2,1 
libsunacl-1.0.1 libtasn1-4.13 libunistring-0.9.10 lzo2-2.10_1 
ncurses-6.1.20180728 nettle-3.4 openldap-client-2.4.46 p11-kit-0.23.14 
pcre-8.42 perl5-5.26.2 popt-1.16_2 py27-setuptools-40.0.0 py36-dnspython-1.15.0 
py36-iso8601-0.1.11 python27-2.7.15 python36-3.6.6_1 readline-7.0.3_1 
talloc-2.1.14 tdb-1.3.16,1 tevent-0.9.37 tpm-emulator-0.7.4_2 trousers-0.3.14_2
WWW:    http://www.samba.org/

You need the second line Path: /usr/ports/net/samba48. This path is called an origin of port. All that you have to do is to make the port:

make -C /usr/ports/net/samba48 install clean

First you'll be asked for the options you want the port to be built with. And the same for all dependencies that have customizable options too. Then the build begins. Be ready that port system begin to fetch and build all the dependencies the choosed software need to be compiled. Also I suspect that you'll be warned that lot of software previously built by hands are already installed. You'll better deinstall and reinstall them all.

Once your software is being installed from ports all that you have to do is to run portsnap fetch update weelky or monthly. Then you can run the tool portmaster -L that list all the software that can be upgraded.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.