0

My setup:

  • My OS is Ubuntu 18.04
  • Vagrant 2.0.0
  • VirtualBox 5.2.18 r124319
  • Ubuntu installed into vagrant/virtualbox (version uknown)

sudo vagrant up was always working, suddenly it has stopped working... it gets stuck on SSH auth method: private key until reach timeout.

So I run sudo vagrant up with GUI enabled to check for errors, and what I found:

Scanning for Btrfs filesystems 
/dev/mapper/vagrant--vg-root: contains a file system with errors, check forced. 
/dev/mapper/vagrant--vg-root: Inodes that were part of a corrupted orphan linked list found.

/dev/mapper/vagrant--vg-root: UNEXPECTED INCONSISTENCY; RUN fsck MANUALLY.  (i.e., without -a or -p options) 
fsck exited with status code 4 
The root filesystem on /dev/mapper/vagrant--vg-root requires manual fsck

How to proceed?

3

I've solved the issue. Here is how:

  • vagrant up with GUI enabled
  • As soon as GUI open, keep pressing Right Shift, select "Advanced Options for Ubuntu" and then select "Ubuntu in Recovery mode"
  • After "/dev/mapper/vagrant--vg-root: UNEXPECTED INCONSISTENCY" appears, run fsck /dev/mapper/vagrant--vg-root pressing Enter everytime the proccess ask to fix an issue
  • vagrant upagain with GUI disabled, problem solved

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.