-2

I start listing my specs:

  • CentOS Linux release 7.5.1804 (Core)

# curl -V curl 7.61.1 (x86_64-pc-linux-gnu) libcurl/7.61.1 Release-Date: 2018-09-05 Protocols: dict file ftp gopher http imap pop3 rtsp smtp telnet tftp Features: AsynchDNS IPv6 Largefile UnixSockets

# curl-config --configure
 --with-ssl
# curl-config --ca

# curl-config --features
IPv6
UnixSockets
AsynchDNS
# 

I have some certificates (i just searched .crt files XD) in these locations:

  • /etc/pki/ca-trust/extracted/openssl
  • /etc/pki/ca-trust/source
  • /etc/pki/tls/certs
  • /tmp/curl-7.61.1/tests/certs
  • /usr/share/pki/ca-trust-legacy
  • /usr/src/ca-certificates/etc/pki/tls/certs
  • /usr/src/ca-certificates/usr/share/pki/ca-trust-legacy/

I read (and I can't find it anymore) about problems in certificate from centos 6 to centos 7.

I installed everything from yum, nothing from source.

Am I missing something?!

Thanks!

EDIT: I forgot...

Here is the error:

# curl https://www.google.com
curl: (1) Protocol "https" not supported or disabled in libcurl
  • A problem perhaps? – Gerard H. Pille Sep 16 '18 at 21:15
  • There's not enough info in the question to be able to form an opinion. Perhaps show what you are running and the resulting error might help. – guzzijason Sep 16 '18 at 21:41
  • Do you need more information? thanks – Raikoug Sep 17 '18 at 0:40
0

I found the problem:

which curl

gave me "/usr/local/bin/curl", and this is not what I expected, so i checked if /usr/bin/curl was working correctly, and it was.

I just checked if something was using this curl, rpm -qf /usr/local/bin/curl and as expected nothing was using it, so I just deleted /usr/local/bin/curl and now everything work properly.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.