4

I'm very new to Linux and installing Samba and I'm trying to make my Centos 7 into a ADDC.
However, whenever I want to configure I get the following message:

Checking for lmdb >= 0.9.16 via header check : not found
Samba AD DC and --enable-selftest requires lmdb 0.9.16 or later

When using yum install lmdb it says it's already installed.

[root@localhost samba-4.9.0]# yum install lmdb
Loaded plugins: fastestmirror Loading mirror speeds from cached hostfile * base: mirrors.standaloneinstaller.com * epel: mirrors.powernet.com.ru * extras: ftp.rezopole.net * updates: distrib-coffee.ipsl.jussieu.fr Package lmdb-0.9.22-2.el7.x86_64 already installed and latest version
Nothing to do

  • 1
    Why are you installing samba from source, and not from packages? – Gerald Schneider Sep 19 '18 at 12:19
  • As I'm very new to this i'm following a guide. howtoforge.com/tutorial/… – user2827958 Sep 19 '18 at 12:27
  • To compile something you need to install the development packages of the dependencies. But the guide you use also links to a guide that uses the system packages instead of compiling samba from source. I suggest you try this approach first, there is usually no reason to use the newest (and least tested) version of a software. This only makes the setup more complicated and error prone in the long run. – Gerald Schneider Sep 19 '18 at 13:01
  • 1
    If you have no clue about Linux, compiling anything from source is a terrible idea, especially something as complex as Samba. Avoid at all costs. – Sven Sep 19 '18 at 13:14
  • 1
    Although you seem to be in way over your head, the actual dependency to install is lmdb-devel, and you might be better off following the Samba guidance than some tutorial: Build Samba from Source, Package Dependencies Required to Build Samba, Setting up Samba as an Active Directory Domain Controller – Colt Sep 19 '18 at 13:32
5

The actual dependency to install (for Red Hat Enterprise Linux 7 / CentOS 7 / Scientific Linux 7) is lmdb-devel.

Rather than following some random tutorial for a now EOL version of Samba, you might be better off following the official (and up to date) Samba guidance: Build Samba from Source, Package Dependencies Required to Build Samba, Setting up Samba as an Active Directory Domain Controller

To be sure, the tutorial to which you linked DOES NOT list the current Samba dependencies for CentOS 7.

3

Everyone is giving you stick for trying to build from source however this is the only way if you want to run SambaAD as specified in all the offical samba guides people have linked.

"Red Hat Enterprise Linux 7 does not include all required packages to build a Samba AD DC. Enable the external Extra Packages for Enterprise Linux (EPEL) repository before you install the packages. For details, see https://fedoraproject.org/wiki/EPEL. Enabling the EPEL repository is not required on CentOS 7 and Scientific Linux 7."

@user2827958 make sure you've got the EPEL repository before you try and install all the packages

1

Ignore the chants. Its the only way to learn. Good on you. I know its a while since you post this, but I put it here for anyone else who may come across this issue.

There is a bug in configure code. Add the following to the end of the configure options.

--without-ldb-lmdb

ie for example:- ./configure --enable-debug --with-ads --with-systemd --with-winbind --without-ldb-lmdb

It seems the parameters got a bit messed up when coded. Bug still in there.

Cheers Joe.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.